aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.6.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-16 10:58:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-17 12:26:57 +0100
commit6612c5e48c94fcfcd2c3ed48f7d8f2650e5b6abe (patch)
treea55806615189072652ffc105640940db5af5437e /meta/recipes-kernel/powertop/powertop_2.6.1.bb
parent0d8bedc75e94827e1d2329b2bd96bcfaee6132d1 (diff)
downloadopenembedded-core-6612c5e48c94fcfcd2c3ed48f7d8f2650e5b6abe.tar.gz
powertop: Upgrade 2.5 -> 2.6.1
Needed to create the directory to avoid B != S build issues. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.6.1.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.6.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.6.1.bb b/meta/recipes-kernel/powertop/powertop_2.6.1.bb
new file mode 100644
index 0000000000..58216c2d15
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.6.1.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Power usage tool"
+DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
+HOMEPAGE = "http://01.org/powertop/"
+BUGTRACKER = "http://bugzilla.lesswatts.org/"
+DEPENDS = "ncurses libnl pciutils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
+
+SRC_URI = "http://01.org/powertop/sites/default/files/downloads/powertop-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "4391e7b0af854ecf722cdf712f24b631"
+SRC_URI[sha256sum] = "034cde6d5bb433fe0d29251d5cde5d4c2948abf05fe29ef10966b659331b20e4"
+
+inherit autotools gettext pkgconfig
+
+# we need to explicitly link with libintl in uClibc systems
+LDFLAGS += "${EXTRA_LDFLAGS}"
+EXTRA_LDFLAGS_libc-uclibc = "-lintl"
+
+# we do not want libncursesw if we can
+do_configure_prepend() {
+ # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
+ sed -i -e "s/ncursesw//g" ${S}/configure.ac
+ mkdir -p ${B}/src/tuning/
+}
+
+inherit update-alternatives
+ALTERNATIVE_${PN} = "powertop"
+ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
+ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
+ALTERNATIVE_PRIORITY = "100"