aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_1.13.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2010-08-27 17:11:02 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 09:50:48 +0100
commitf2011318ece69ab27bad24f474d54422709bdc8f (patch)
tree2caf6447769492939274148be7d01133d33008e5 /meta/recipes-kernel/powertop/powertop_1.13.bb
parentdf894c658d9df87b0b04fbb494d46d8eff0fd497 (diff)
downloadopenembedded-core-f2011318ece69ab27bad24f474d54422709bdc8f.tar.gz
powertop: upgrade from 1.11 to the latest version 1.13
update HOMEPAGE; add RRECOMMENDS_${PN} = "pciutils" as powertop 1.13 needs lspci; add EXTRA_OEMAKE = "VERSION=\"${PV}\" to make the build succeed; fix coding style: 4 SPACEs --> 1 TAB. fix RRECOMMENDS to RDEPENDS Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_1.13.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_1.13.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_1.13.bb b/meta/recipes-kernel/powertop/powertop_1.13.bb
new file mode 100644
index 0000000000..c52f2830b8
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_1.13.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
+HOMEPAGE = "http://www.lesswatts.org/"
+BUGTRACKER = "http://bugzilla.lesswatts.org/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "virtual/libintl ncurses"
+
+# powertop 1.13 needs lspci
+REPENDS_${PN} = "pciutils"
+
+PR = "r0"
+
+SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
+
+CFLAGS += "${LDFLAGS}"
+EXTRA_OEMAKE = "VERSION=\"${PV}\""
+
+do_configure() {
+ # We do not build ncurses with wide char support
+ sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+