aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_1.13.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2010-08-27 21:02:34 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 09:50:48 +0100
commit6c098ebe424c4cdc39a93b4e50ff59b4b7894c98 (patch)
tree6c5290392008393b9248713034878e05f2fd2b4a /meta/recipes-kernel/powertop/powertop_1.13.bb
parentf2011318ece69ab27bad24f474d54422709bdc8f (diff)
downloadopenembedded-core-6c098ebe424c4cdc39a93b4e50ff59b4b7894c98.tar.gz
powertop: fix segfault in dump mode
The cause is: in dump mode, setup_windows() is not invoked so the *_window variables, like cstate_window, are still NULL; later in main() -> show_cstates(), the functions, like wrefresh(), will trigger segfault. After discussing in PowerTop mailling list, I think the right solution is we should stub out the ncurses calls in dump mode. (The patch was also sent to upstream PowerTop mailling list.) This fixes [BUGID #195]: Bug 195 - [sdk] powertop segfault when running with dump option Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_1.13.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_1.13.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_1.13.bb b/meta/recipes-kernel/powertop/powertop_1.13.bb
index c52f2830b8..c16f1aca63 100644
--- a/meta/recipes-kernel/powertop/powertop_1.13.bb
+++ b/meta/recipes-kernel/powertop/powertop_1.13.bb
@@ -12,7 +12,8 @@ REPENDS_${PN} = "pciutils"
PR = "r0"
-SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
+SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz \
+ file://stub_out_the_ncurses_calls_in_dump_mode.patch"
CFLAGS += "${LDFLAGS}"
EXTRA_OEMAKE = "VERSION=\"${PV}\""