aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-07-09 12:07:09 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-10 20:25:24 +0100
commit414d00be5b350ea84fc7e1ff690f78b3396cfcd0 (patch)
treee03221bf424f46f1ac9f74b443697818fc962a42 /meta/recipes-kernel/perf
parent9d75c34948f5d961cff9d72fbaa628ff58821cc7 (diff)
downloadopenembedded-core-414d00be5b350ea84fc7e1ff690f78b3396cfcd0.tar.gz
perf: add perf.inc
Add a perf.inc to contain utility functions and definitions and to avoid cluttering up the main recipe. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf')
-rw-r--r--meta/recipes-kernel/perf/perf.inc22
-rw-r--r--meta/recipes-kernel/perf/perf_3.4.bb2
2 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.inc b/meta/recipes-kernel/perf/perf.inc
new file mode 100644
index 0000000000..d112751417
--- /dev/null
+++ b/meta/recipes-kernel/perf/perf.inc
@@ -0,0 +1,22 @@
+PERF_FEATURES_ENABLE ?= "perf-scripting perf-tui"
+
+def perf_feature_enabled(feature, trueval, falseval, d):
+ """
+ Check which perf features are enabled.
+
+ The PERF_FEATURES_ENABLE variable lists the perf features to
+ enable. Override it if you want something different from what's
+ listed above, which is the default. If empty, the build won't
+ enable any features (which may be exactly what you want, just a
+ barebones perf without any extra baggage, what you get if you
+ specify an empty feature list).
+
+ Available perf features:
+ perf-scripting: enable support for Perl and Python bindings
+ perf-tui: enable support for the perf TUI (via libnewt)
+
+ """
+ enabled_features = d.getVar("PERF_FEATURES_ENABLE", True) or ""
+ if feature in enabled_features:
+ return trueval
+ return falseval
diff --git a/meta/recipes-kernel/perf/perf_3.4.bb b/meta/recipes-kernel/perf/perf_3.4.bb
index 381332e7b7..d49424309d 100644
--- a/meta/recipes-kernel/perf/perf_3.4.bb
+++ b/meta/recipes-kernel/perf/perf_3.4.bb
@@ -11,6 +11,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
PR = "r1"
+require perf.inc
+
BUILDPERF_libc-uclibc = "no"
DEPENDS = "virtual/kernel \