summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_5.8.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-08-19 09:24:40 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-20 15:28:57 +0100
commit18edf84ec6cfcc137602f89ddc024d1fe1dcf03a (patch)
tree8a156413138e359109922a5677e95d32d07aaff1 /meta/recipes-kernel/linux/linux-yocto_5.8.bb
parent4c3750bbc9dae30d91bd0e5efc8f614810289b31 (diff)
downloadopenembedded-core-18edf84ec6cfcc137602f89ddc024d1fe1dcf03a.tar.gz
linux-yocto: introduce 5.8 reference kernel
Add the next set of "versioned" linux-yocto recipes that can be used to build v5.8 upstream (v5.8/base) or 5.8 with some emedded specific features (v5.8/standard/*). Note: along with the new 5.8 content, the recipes have a tweaked licence checksum, which The needs to be updated to account for kernel commit 74835c7db0322b [COPYING: state that all contributions really are covered by this file]. These have been built and booted for all supported qemu architectures. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_5.8.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.8.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.8.bb b/meta/recipes-kernel/linux/linux-yocto_5.8.bb
new file mode 100644
index 0000000000..f9d23072fd
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_5.8.bb
@@ -0,0 +1,54 @@
+KBRANCH ?= "v5.8/standard/base"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+# board specific branches
+KBRANCH_qemuarm ?= "v5.8/standard/arm-versatile-926ejs"
+KBRANCH_qemuarm64 ?= "v5.8/standard/qemuarm64"
+KBRANCH_qemumips ?= "v5.8/standard/mti-malta32"
+KBRANCH_qemuppc ?= "v5.8/standard/qemuppc"
+KBRANCH_qemuriscv64 ?= "v5.8/standard/base"
+KBRANCH_qemux86 ?= "v5.8/standard/base"
+KBRANCH_qemux86-64 ?= "v5.8/standard/base"
+KBRANCH_qemumips64 ?= "v5.8/standard/mti-malta64"
+
+SRCREV_machine_qemuarm ?= "e6215284f772360ed2110b2f9b5ab5cfbeb60550"
+SRCREV_machine_qemuarm64 ?= "581a55ca5571041bc5885febe8415c5751c489d9"
+SRCREV_machine_qemumips ?= "421057004e4e9847219dc966ecebe3174bf9c670"
+SRCREV_machine_qemuppc ?= "581a55ca5571041bc5885febe8415c5751c489d9"
+SRCREV_machine_qemuriscv64 ?= "581a55ca5571041bc5885febe8415c5751c489d9"
+SRCREV_machine_qemux86 ?= "581a55ca5571041bc5885febe8415c5751c489d9"
+SRCREV_machine_qemux86-64 ?= "581a55ca5571041bc5885febe8415c5751c489d9"
+SRCREV_machine_qemumips64 ?= "b3f4fce505798c95cdce90a9551cbf68de7bd811"
+SRCREV_machine ?= "581a55ca5571041bc5885febe8415c5751c489d9"
+SRCREV_meta ?= "4c62a6f4fa227abacf87f1593faa1ac6e6616156"
+
+# remap qemuarm to qemuarma15 for the 5.8 kernel
+# KMACHINE_qemuarm ?= "qemuarma15"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.8;destsuffix=${KMETA}"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+LINUX_VERSION ?= "5.8"
+
+DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "openssl-native util-linux-native"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+KMETA = "kernel-meta"
+KCONF_BSP_AUDIT_LEVEL = "1"
+
+KERNEL_DEVICETREE_qemuarmv5 = "versatile-pb.dtb"
+
+COMPATIBLE_MACHINE = "qemuarm|qemuarmv5|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64|qemuriscv64"
+
+# Functionality flags
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
+KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
+KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"
+KERNEL_FEATURES_append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc", "" ,d)}"