aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.4.bb
diff options
context:
space:
mode:
authorLiang Li <liang.li@windriver.com>2012-08-22 16:02:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-25 14:44:00 +0100
commit4e0daf05ed04e9fb4343032c6290a379f53b89f3 (patch)
tree50e7b3d44ea217eb6507485625651c20bba0a637 /meta/recipes-kernel/linux/linux-yocto_3.4.bb
parent20e2aaacb36113604c4ea7c40dd0bbbf224b8360 (diff)
downloadopenembedded-core-4e0daf05ed04e9fb4343032c6290a379f53b89f3.tar.gz
kernel.bbclass: fix INC directory for SLANG
In the kernel's tools/perf/Makefile CFLAGS was previously hard coded to contain "-I/usr/include/slang" to work with hosts that have "/usr/include/slang/slang.h" as well as hosts that have "/usr/include/slang.h". This path can cause compile warnings like: cc1: warning: '/usr/include/slang' doesn't exists. or cc1: warning: include location "/usr/include/slang" is unsafe for cross-compilation [-Wpoison-system-directories] Then in some cases warnings become errors if WERROR is enabled hence build errors. In coordination with a kernel fix, we can fix this error for all kernels by modifying the perf Makefile within the staged kernel source. Signed-off-by: Liang Li <liang.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
index 691d78968a..440deef57e 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
@@ -13,11 +13,9 @@ SRCREV_meta ?= "28bcd46af1d592dab39bd8a0891c872454fde8bc"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
-SRC_URI += "file://noslang.patch"
-
LINUX_VERSION ?= "3.4.7"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "meta"