aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.10.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-08-23 14:08:20 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-26 11:25:59 +0100
commit6dc46834c6edaf358c18b26e4304bc9e7413eb60 (patch)
tree1c66a966de3a86d276c5a7d7740a5a605c390e1d /meta/recipes-kernel/linux/linux-yocto_3.10.bb
parent1e35d04067357b1c65d9e2c4796acfa02274fd9d (diff)
downloadopenembedded-core-6dc46834c6edaf358c18b26e4304bc9e7413eb60.tar.gz
linux-yocto: introduce v3.10
Introduce the 3.10 kernel. This is based on the 3.10.9 upstream kernel and replaces the 3.8 recipes, which will be removed once all reference boards have been updated. 3.10 also the latest LTSI and will be updated with that content when it becomes available. Other features of the 3.10 kernel include: - refreshed -rt support - refreshed yaffs2, aufs3 - cryptodev - bfs, edf, and OCF staged features - scrubbed and updated meta data for v3.10 - improved tools support for meta data updates and queue maintenance - patch carry forward from all previous linux-yocto kernels and configuration. This kernel has been built and boot tested on all qemu machines and architectures. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.10.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.10.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.10.bb b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
new file mode 100644
index 0000000000..ea6ad2a74d
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
@@ -0,0 +1,30 @@
+require recipes-kernel/linux/linux-yocto.inc
+
+KBRANCH_DEFAULT = "standard/base"
+KBRANCH = "${KBRANCH_DEFAULT}"
+
+SRCREV_machine_qemuarm ?= "8675d3d0a3c17135f70ef474d5c362397c02e62a"
+SRCREV_machine_qemumips ?= "992b743b905edd21d3a4a27c92b5c6a9e44d7d73"
+SRCREV_machine_qemuppc ?= "09388c3572e26c78b34554e46e077f12be7b2401"
+SRCREV_machine_qemux86 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
+SRCREV_machine_qemux86-64 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
+SRCREV_machine_qemumips64 ?= "203679cb23c752fdcbc0180a55a81728d7462561"
+SRCREV_machine ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
+SRCREV_meta ?= "1b9b113837f353fd94148beb6bd00a3b7b35d01d"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"
+
+LINUX_VERSION ?= "3.10.9"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+KMETA = "meta"
+
+COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
+
+# Functionality flags
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
+KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
+KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"