summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-08-19 09:24:40 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-20 15:28:57 +0100
commit18edf84ec6cfcc137602f89ddc024d1fe1dcf03a (patch)
tree8a156413138e359109922a5677e95d32d07aaff1 /meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
parent4c3750bbc9dae30d91bd0e5efc8f614810289b31 (diff)
downloadopenembedded-core-18edf84ec6cfcc137602f89ddc024d1fe1dcf03a.tar.gz
linux-yocto: introduce 5.8 reference kernel
Add the next set of "versioned" linux-yocto recipes that can be used to build v5.8 upstream (v5.8/base) or 5.8 with some emedded specific features (v5.8/standard/*). Note: along with the new 5.8 content, the recipes have a tweaked licence checksum, which The needs to be updated to account for kernel commit 74835c7db0322b [COPYING: state that all contributions really are covered by this file]. These have been built and booted for all supported qemu architectures. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
new file mode 100644
index 0000000000..1d52bfeeba
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
@@ -0,0 +1,32 @@
+KBRANCH ?= "v5.8/standard/tiny/base"
+KBRANCH_qemuarm ?= "v5.8/standard/tiny/arm-versatile-926ejs"
+
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_VERSION ?= "5.8"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+
+DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "openssl-native util-linux-native"
+
+KMETA = "kernel-meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
+
+SRCREV_machine_qemuarm ?= "8c6b76ac37ee5c0f09ffff816a6519f3f8ea6582"
+SRCREV_machine ?= "581a55ca5571041bc5885febe8415c5751c489d9"
+SRCREV_meta ?= "4c62a6f4fa227abacf87f1593faa1ac6e6616156"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.8;destsuffix=${KMETA}"
+
+COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
+
+# Functionality flags
+KERNEL_FEATURES = ""
+
+KERNEL_DEVICETREE_qemuarmv5 = "versatile-pb.dtb"