summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/cryptodev/cryptodev-tests_1.11.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-08-23 22:20:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-25 15:59:52 +0100
commit7d1532e4dc0dfe78660bb076018847aaf3fa8f2f (patch)
treef85e75cc7582012d040e6522022d32b7e7fadae8 /meta/recipes-kernel/cryptodev/cryptodev-tests_1.11.bb
parent44c5414c0ce32eb496d53527f2fd6da8d31c5882 (diff)
downloadopenembedded-core-7d1532e4dc0dfe78660bb076018847aaf3fa8f2f.tar.gz
cryptodev: upgrade 1.10 -> 1.11
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/cryptodev/cryptodev-tests_1.11.bb')
-rw-r--r--meta/recipes-kernel/cryptodev/cryptodev-tests_1.11.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-tests_1.11.bb b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.11.bb
new file mode 100644
index 0000000000..9cb5dcb94f
--- /dev/null
+++ b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.11.bb
@@ -0,0 +1,21 @@
+require cryptodev.inc
+
+SUMMARY = "A test suite for /dev/crypto device driver"
+
+DEPENDS += "openssl"
+
+SRC_URI += " \
+file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
+"
+
+EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" PREFIX="${D}"'
+
+do_compile() {
+ oe_runmake testprogs
+}
+
+do_install() {
+ oe_runmake install_tests
+}
+
+FILES_${PN} = "${bindir}/*"