summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-04-22 09:37:33 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-23 10:10:43 +0100
commitd5455a8f636599d6be8c36ea1578274148d558df (patch)
treea05cbbff27fc0144811cb73fe7843d1069a7a97a /meta/recipes-graphics
parent00ce2796d97de2bc376b038d0ea7969088791d34 (diff)
downloadopenembedded-core-d5455a8f636599d6be8c36ea1578274148d558df.tar.gz
xwayland: add opengl to REQUIRED_DISTRO_FEATURES
* it depends on libepoxy which has this restriction * fixes: ERROR: Nothing PROVIDES 'libepoxy' (but openembedded-core/meta/recipes-graphics/xwayland/xwayland_21.1.1.bb DEPENDS on or otherwise requires it) libepoxy was skipped: missing required distro feature 'opengl' (not in DISTRO_FEATURES) ERROR: Nothing RPROVIDES 'xwayland' (but openembedded-core/meta/recipes-graphics/xwayland/xwayland_21.1.1.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'xwayland' NOTE: Runtime target 'xwayland' is unbuildable, removing... Missing or unbuildable dependency chain was: ['xwayland'] ERROR: Nothing RPROVIDES 'xwayland-dev' (but openembedded-core/meta/recipes-graphics/xwayland/xwayland_21.1.1.bb RDEPENDS on or otherwise requires it) No eligible RPROVIDERs exist for 'xwayland-dev' NOTE: Runtime target 'xwayland-dev' is unbuildable, removing... Missing or unbuildable dependency chain was: ['xwayland-dev'] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xwayland/xwayland_21.1.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/xwayland/xwayland_21.1.1.bb b/meta/recipes-graphics/xwayland/xwayland_21.1.1.bb
index 82765cdaf9..b2ff25fbbc 100644
--- a/meta/recipes-graphics/xwayland/xwayland_21.1.1.bb
+++ b/meta/recipes-graphics/xwayland/xwayland_21.1.1.bb
@@ -13,7 +13,7 @@ SRC_URI = "https://www.x.org/archive/individual/xserver/xwayland-${PV}.tar.xz"
SRC_URI[sha256sum] = "31f261ce51bbee76a6ca3ec02aa367ffa2b5efa2b98412df57ccefd7a19003ce"
inherit meson features_check
-REQUIRED_DISTRO_FEATURES = "x11"
+REQUIRED_DISTRO_FEATURES = "x11 opengl"
DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy"