aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorBen Shelton <ben.shelton@ni.com>2015-02-20 13:02:33 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-21 22:04:25 +0000
commita1598266c828ad0b73df971b22d6a2e3e1dd5cab (patch)
treec10537f8eb7d9dfc244fba38fa403723dc31188a /meta/recipes-graphics
parentbb8a7b906204b25f07fe568883c2d605593c323c (diff)
downloadopenembedded-core-a1598266c828ad0b73df971b22d6a2e3e1dd5cab.tar.gz
font-util: stage encoding maps into sysroot
font-util installs encoding maps into /usr/share/fonts/X11. This path may not exist on the host (many distros install these into /usr/share/fonts/util) so they must exist in the sysroot in order for e.g. `pkg-config --variable=mapdir fontutil` to work correctly. However, currently /usr/share/fonts is explicitly not installed into sysroots, so the encoding maps were not getting found. Fix this by explicitly staging ${datadir}/fonts/ into the sysroot. Signed-off-by: Ben Shelton <ben.shelton@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-font/font-util_1.3.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-font/font-util_1.3.0.bb b/meta/recipes-graphics/xorg-font/font-util_1.3.0.bb
index cc4258ad7b..a067a75869 100644
--- a/meta/recipes-graphics/xorg-font/font-util_1.3.0.bb
+++ b/meta/recipes-graphics/xorg-font/font-util_1.3.0.bb
@@ -24,3 +24,8 @@ BBCLASSEXTEND = "native"
SRC_URI[md5sum] = "ddfc8a89d597651408369d940d03d06b"
SRC_URI[sha256sum] = "dfa9e55625a4e0250f32fabab1fd5c8ffcd2d1ff2720d6fcf0f74bc8a5929195"
+
+SYSROOT_PREPROCESS_FUNCS += "fontutil_sysroot_preprocess"
+fontutil_sysroot_preprocess () {
+ sysroot_stage_dir ${D}${datadir}/fonts/ ${SYSROOT_DESTDIR}${datadir}/fonts/
+}