summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorPetr Kubizňák <kubiznak@2n.com>2023-01-04 12:45:55 +0100
committerSteve Sakoman <steve@sakoman.com>2023-01-19 16:28:32 -1000
commit687f371fc99833b878f3cfdb006aca9e238d9909 (patch)
treec78dd5135ddc3433cf59cbeec8f042324fa56621 /meta/recipes-graphics
parentfdce8ecdc27796955156b9c4a91ccaca80459ec5 (diff)
downloadopenembedded-core-687f371fc99833b878f3cfdb006aca9e238d9909.tar.gz
harfbuzz: remove bindir only if it exists
In some scenarios (e.g. when "glib" removed from PACKAGECONFIG), "${D}${bindir}" might not exist which caused `rmdir` to fail. Signed-off-by: Petr Kubizňák <kubiznak@2n.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 21261072cbe0056e85550a0710de142fab8943e4) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb
index 4905e8e2ad..8e06acc011 100644
--- a/meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_5.1.0.bb
@@ -32,9 +32,9 @@ PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
LEAD_SONAME = "libharfbuzz.so"
do_install:append() {
- # If no tools are installed due to PACKAGECONFIG then this directory is
- #still installed, so remove it to stop packaging wanings.
- rmdir --ignore-fail-on-non-empty ${D}${bindir}
+ # If no tools are installed due to PACKAGECONFIG then this directory might
+ # still be installed, so remove it to stop packaging warnings.
+ [ ! -d ${D}${bindir} ] || rmdir --ignore-fail-on-non-empty ${D}${bindir}
}
FILES:${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"