summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2022-10-17 16:05:58 +0200
committerSteve Sakoman <steve@sakoman.com>2022-11-04 09:16:52 -1000
commit58f93fcc5364880f11f1d86e0a5a6c5712f6ca6a (patch)
treeddc341ff71fd4fefb566c5d0e7a80d701f63fb0e /meta/recipes-graphics
parent803975aff35c9423f4bde4c0201d0f61242389e0 (diff)
downloadopenembedded-core-58f93fcc5364880f11f1d86e0a5a6c5712f6ca6a.tar.gz
vulkan-samples: add lfs=0 to SRC_URI to avoid git smudge errors in do_unpack
* we don't need other_lib/ios/Debug-iphoneos/libSDL2.a from https://github.com/KhronosGroup/KTX-Software.git so we can explicitly disable LFS here to avoid do_unpack error, bitbake will then use GIT_LFS_SKIP_SMUDGE=1 to override smudge setting in gitconfig, otherwise we would need bitbake patch to fetch LFS objects from the submodules as well * do_fetch won't fetch LFS objects without explicitly requesting lfs in SRC_URI then do_unpack might run git smudge when enabled in .gitconfig (or /etc/gitconfig) with: [filter "lfs"] smudge = git-lfs smudge -- %f process = git-lfs filter-process required = true clean = git-lfs clean -- %f and do_unpack fails as in: http://errors.yoctoproject.org/Errors/Details/672888/ The default /etc/gitconfig in ubuntu has this added automatically by git-lfs postinst: root@ljama:~# rm /etc/gitconfig root@ljama:~# git lfs install --skip-repo --system Git LFS initialized. root@ljama:~# cat /etc/gitconfig [filter "lfs"] clean = git-lfs clean -- %f smudge = git-lfs smudge -- %f process = git-lfs filter-process required = true root@ljama:~# cat /var/lib/dpkg/info/git-lfs.postinst set -e # Set up /etc/gitconfig for git-lfs. The --skip-repo option prevents failure if # / is a Git repository with existing non-git-lfs hooks. git lfs install --skip-repo --system > /dev/null 2>&1 according to https://changelogs.ubuntu.com/changelogs/pool/universe/g/git-lfs/git-lfs_3.0.2-1/changelog it was added in: git-lfs (2.6.0-1) unstable; urgency=medium * New upstream release * Bump standards version to 4.2.1 * Add postinst/prerm to set up/remove git-lfs gitconfig FWIW: vulkan-samples still fail to build with DEBUG_BUILD enabled: http://errors.yoctoproject.org/Errors/Details/672892/ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> (cherry picked from commit b45b1f5dba02a626b7e9040d45198bd17dce4c99) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-samples_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan-samples_git.bb b/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
index 332411b312..d0b3458e1b 100644
--- a/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
-SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=master;protocol=https \
+SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=master;protocol=https;lfs=0 \
file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \
file://debugfix.patch \
file://0001-Qualify-move-as-std-move.patch;patchdir=third_party/spirv-cross \