summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2022-11-10 03:01:36 +0100
committerSteve Sakoman <steve@sakoman.com>2022-11-21 06:39:37 -1000
commit0a449acddca1ba9022c9ffd8af0d9ac5ad2c4e4c (patch)
tree8d4d18facc8533d82678eafe29db60ab0f921ea2 /meta/recipes-graphics
parentc1c3a2f3d4bb002be241d37cde688c6e9d8c0bea (diff)
downloadopenembedded-core-0a449acddca1ba9022c9ffd8af0d9ac5ad2c4e4c.tar.gz
pango: Make it build with ptest disabled
This avoids the following error: ERROR: pango-1.50.11-r0 do_package: QA Issue: pango: Files/directories were installed but not shipped in any package: /usr/libexec /usr/libexec/installed-tests /usr/libexec/installed-tests/pango /usr/libexec/installed-tests/pango/nofonts /usr/libexec/installed-tests/pango/nofonts/fonts.conf Also use tabs for indentation of shell code. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit d4bcd4050a6a9b6b1cb8e68b2053523cc0501814) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/pango/pango_1.50.11.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.50.11.bb b/meta/recipes-graphics/pango/pango_1.50.11.bb
index f545689811..f982d9a65b 100644
--- a/meta/recipes-graphics/pango/pango_1.50.11.bb
+++ b/meta/recipes-graphics/pango/pango_1.50.11.bb
@@ -38,13 +38,15 @@ PACKAGECONFIG[thai] = ",,libthai"
GIR_MESON_OPTION = 'introspection'
do_configure:prepend() {
- chmod +x ${S}/tests/*.py
+ chmod +x ${S}/tests/*.py
}
# https://gitlab.gnome.org/GNOME/pango/-/issues/713
do_install:append() {
- mkdir -p ${D}/${libexecdir}/installed-tests/pango/nofonts/
- install ${S}/tests/nofonts/fonts.conf ${D}/${libexecdir}/installed-tests/pango/nofonts/
+ if [ "${@bb.utils.filter('PACKAGECONFIG', 'tests', d)}" ]; then
+ mkdir -p ${D}${libexecdir}/installed-tests/pango/nofonts
+ install ${S}/tests/nofonts/fonts.conf ${D}${libexecdir}/installed-tests/pango/nofonts
+ fi
}
LEAD_SONAME = "libpango-1.0*"