aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-10-27 16:48:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-02 16:15:30 +0000
commitd37944fff256e9f52d05a56db3edb42c7a352cce (patch)
tree1a6f50ac8c5185608069141fc4053a8a72da3696 /meta/recipes-gnome
parent7c7da0af592647be0ab9ab37a8ad2a7ce4890a46 (diff)
downloadopenembedded-core-d37944fff256e9f52d05a56db3edb42c7a352cce.tar.gz
recipes-gnome: replace virtclass-native(sdk) with class-native(sdk)
The overrides virtclass-native and virtclass-nativesdk are deprecated, which should be replaced by class-native and class-nativesdk. [YOCTO #3297] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb6
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.3.bb6
-rw-r--r--meta/recipes-gnome/gnome/gnome-doc-utils.inc4
-rw-r--r--meta/recipes-gnome/gtk+/gtk+_2.24.8.bb4
-rw-r--r--meta/recipes-gnome/librsvg/librsvg_2.32.1.bb4
5 files changed, 12 insertions, 12 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb
index a77eee1164..65a2d68fd1 100644
--- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb
+++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb
@@ -35,7 +35,7 @@ EXTRA_OECONF = "\
"
X11DEPENDS = "--without-x11"
X11DEPENDS_linuxstdbase = "${@base_contains('DISTRO_FEATURES', 'x11', '--with-x11', '--without-x11', d)}"
-X11DEPENDS_virtclass-native = "--without-x11"
+X11DEPENDS_class-native = "--without-x11"
PACKAGES =+ "${PN}-xlib"
@@ -73,7 +73,7 @@ fi
}
PACKAGES_DYNAMIC += "^gdk-pixbuf-loader-.*"
-PACKAGES_DYNAMIC_virtclass-native = ""
+PACKAGES_DYNAMIC_class-native = ""
python populate_packages_prepend () {
postinst_pixbufloader = d.getVar("postinst_pixbufloader", True)
@@ -83,7 +83,7 @@ python populate_packages_prepend () {
do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s', postinst_pixbufloader)
}
-do_install_append_virtclass-native() {
+do_install_append_class-native() {
#Use wrapper script rather than binary as required libtool library is not installed now
GDK_PIXBUF_MODULEDIR=${D}${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders ${S}/gdk-pixbuf/gdk-pixbuf-query-loaders > ${D}${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
sed -i -e 's#${D}##g' ${D}${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.3.bb b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
index 4d77a14f81..f80c9104ed 100644
--- a/meta/recipes-gnome/gnome/gconf_3.2.3.bb
+++ b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
@@ -7,7 +7,7 @@ POLKIT = "polkit"
POLKIT_libc-uclibc = ""
DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native ${POLKIT} gobject-introspection-stub"
-DEPENDS_virtclass-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native gobject-introspection-stub-native"
+DEPENDS_class-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native gobject-introspection-stub-native"
PR = "r12"
@@ -22,7 +22,7 @@ SRC_URI[archive.sha256sum] = "52008a82a847527877d9e1e549a351c86cc53cada4733b8a70
S = "${WORKDIR}/GConf-${PV}"
POLKIT_OECONF = "--enable-defaults-service"
-POLKIT_OECONF_virtclass-native = "--disable-defaults-service"
+POLKIT_OECONF_class-native = "--disable-defaults-service"
POLKIT_OECONF_libc-uclibc = "--disable-default-service"
EXTRA_OECONF = "--enable-shared --disable-static --enable-debug=yes \
@@ -39,7 +39,7 @@ do_install_append() {
# disable dbus-x11 when x11 isn't in DISTRO_FEATURES
RDEPENDS_${PN} += "${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)}"
-RDEPENDS_${PN}_virtclass-native = ""
+RDEPENDS_${PN}_class-native = ""
FILES_${PN} += "${libdir}/GConf/* \
${libdir}/gio/*/*.so \
diff --git a/meta/recipes-gnome/gnome/gnome-doc-utils.inc b/meta/recipes-gnome/gnome/gnome-doc-utils.inc
index b2570d6fd6..8ea0b96baf 100644
--- a/meta/recipes-gnome/gnome/gnome-doc-utils.inc
+++ b/meta/recipes-gnome/gnome/gnome-doc-utils.inc
@@ -1,6 +1,6 @@
LICENSE = "GPLv2 & LGPLv2.1"
DEPENDS = "libxml2 libxslt libxslt-native gnome-doc-utils-native glib-2.0"
-DEPENDS_virtclass-native = "libxml2-native libxslt-native intltool-native glib-2.0-native"
+DEPENDS_class-native = "libxml2-native libxslt-native intltool-native glib-2.0-native"
inherit gnome gettext python-dir pythonnative
@@ -20,6 +20,6 @@ do_install_append_class-native () {
FILES_${PN} += "${datadir}/xml* ${PYTHON_SITEPACKAGES_DIR}/*"
RDEPENDS_${PN} = "bash"
-RDEPENDS_${PN}_virtclass-native = ""
+RDEPENDS_${PN}_class-native = ""
BBCLASSEXTEND = "native"
diff --git a/meta/recipes-gnome/gtk+/gtk+_2.24.8.bb b/meta/recipes-gnome/gtk+/gtk+_2.24.8.bb
index 5481f82b64..bbf765b7f0 100644
--- a/meta/recipes-gnome/gtk+/gtk+_2.24.8.bb
+++ b/meta/recipes-gnome/gtk+/gtk+_2.24.8.bb
@@ -38,8 +38,8 @@ LIBV = "2.10.0"
PACKAGES_DYNAMIC += "^gtk-immodule-.* ^gtk-printbackend-.*"
BBCLASSEXTEND = "native"
-RRECOMMENDS_${PN}_virtclass-native = ""
-DEPENDS_virtclass-native = "glib-2.0-native atk-native pango-native cairo-native gdk-pixbuf-native"
+RRECOMMENDS_${PN}_class-native = ""
+DEPENDS_class-native = "glib-2.0-native atk-native pango-native cairo-native gdk-pixbuf-native"
python populate_packages_prepend () {
prologue = d.getVar("postinst_prologue", True)
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb b/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb
index 100b51e8a8..4f838e0318 100644
--- a/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb
+++ b/meta/recipes-gnome/librsvg/librsvg_2.32.1.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
SECTION = "x11/utils"
DEPENDS = "gtk+ cairo libxml2"
-DEPENDS_virtclass-native = "cairo-native pango-native gdk-pixbuf-native"
+DEPENDS_class-native = "cairo-native pango-native gdk-pixbuf-native"
BBCLASSEXTEND = "native"
PR = "r10"
@@ -19,7 +19,7 @@ EXTRA_OECONF = "--disable-mozilla-plugin --without-svgz"
PACKAGECONFIG ??= "croco"
# When native we can manage without croco, as it's only for GTK+
-PACKAGECONFIG_virtclass-native = ""
+PACKAGECONFIG_class-native = ""
PACKAGECONFIG[croco] = "--with-croco,--without-croco,libcroco"