aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-12-17 14:32:42 +0200
committerSaul Wold <sgw@linux.intel.com>2012-12-18 23:48:22 -0800
commitbba414bc9d14eb2d29b54c68259d13ddbe6567fa (patch)
tree23f74e89c22c6f2bb1f3058f03512c3713d96371 /meta/recipes-gnome
parentc42ca31e34ffa3eed17407245a51322f2700e630 (diff)
downloadopenembedded-core-bba414bc9d14eb2d29b54c68259d13ddbe6567fa.tar.gz
gconf: add gconftool-2 native wrapper
This is needed when sstate cache is fetched from another build server. In this case, the postinstall will fail because the backend libraries path will be from the build server. Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.3.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.3.bb b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
index f80c9104ed..ef21624de1 100644
--- a/meta/recipes-gnome/gnome/gconf_3.2.3.bb
+++ b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
@@ -9,7 +9,7 @@ POLKIT_libc-uclibc = ""
DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native ${POLKIT} gobject-introspection-stub"
DEPENDS_class-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native gobject-introspection-stub-native"
-PR = "r12"
+PR = "r13"
inherit gnomebase gtk-doc
@@ -37,6 +37,11 @@ do_install_append() {
rm -f ${D}${libdir}/gio/*/*.*a
}
+do_install_append_class-native() {
+ create_wrapper ${D}/${bindir}/gconftool-2 \
+ GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
+}
+
# disable dbus-x11 when x11 isn't in DISTRO_FEATURES
RDEPENDS_${PN} += "${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)}"
RDEPENDS_${PN}_class-native = ""