aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/packagegroups
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-07-26 18:16:14 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:50 -0700
commit65fca4458cfe1d647c7ea1d4588dc449739a73eb (patch)
tree66ab6e610c025dbf9fcd5480324c043e06125182 /meta/recipes-gnome/packagegroups
parent3a3ae22bc0be5b36e0400986930f30c22a61a74e (diff)
downloadopenembedded-core-65fca4458cfe1d647c7ea1d4588dc449739a73eb.tar.gz
packagegroup-*: change to inherit from packagegroup.bbclass
Also clean out items already handled by that class (dev/dbg packages, ALLOW_EMPTY, etc.) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-gnome/packagegroups')
-rw-r--r--meta/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bb4
-rw-r--r--meta/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bb b/meta/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bb
index a00ca36901..45cffa4b76 100644
--- a/meta/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bb
+++ b/meta/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bb
@@ -8,11 +8,11 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PR = "r12"
-ALLOW_EMPTY = "1"
+inherit packagegroup
require packagegroup-sdk-gmae.inc
-PACKAGES = "${PN}"
+PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
RDEPENDS_${PN} = "\
packagegroup-core-sdk \
diff --git a/meta/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bb b/meta/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bb
index 3b2abddcdc..79b3253a75 100644
--- a/meta/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bb
+++ b/meta/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bb
@@ -8,11 +8,11 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PR = "r14"
-ALLOW_EMPTY = "1"
+inherit packagegroup
require packagegroup-sdk-gmae.inc
-PACKAGES = "${PN} ${PN}-dbg"
+PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
RDEPENDS_${PN} = "\
packagegroup-core-standalone-sdk-target \