aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/packagegroups
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-04 17:43:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 18:03:13 +0100
commit5dd4de086d744c81d2275077ad0e0022204b0a68 (patch)
tree6ec64251dbcabb7098fcfd5157b800fb8ebc5490 /meta/recipes-gnome/packagegroups
parentc65f8af02ebba371f96119baef0520c6685c7167 (diff)
downloadopenembedded-core-5dd4de086d744c81d2275077ad0e0022204b0a68.tar.gz
packagegroup-*: add RREPLACES/RCONFLICTS
These are needed to support upgrading from task-* to packagegroup-* within existing target images at runtime. Note: these settings will very likely be moved out to a separate inc file at some point in the future. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/packagegroups')
-rw-r--r--meta/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bb4
-rw-r--r--meta/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bb4
2 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bb b/meta/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bb
index e959c5be6c..d42ea7ea1d 100644
--- a/meta/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bb
+++ b/meta/recipes-gnome/packagegroups/packagegroup-core-sdk-gmae.bb
@@ -4,7 +4,7 @@
SUMMARY = "GNOME Mobile And Embedded SDK (host tools)"
LICENSE = "MIT"
-PR = "r12"
+PR = "r13"
inherit packagegroup
@@ -14,6 +14,8 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
# For backwards compatibility after rename
RPROVIDES_${PN} = "task-core-sdk-gmae"
+RREPLACES_${PN} = "task-core-sdk-gmae"
+RCONFLICTS_${PN} = "task-core-sdk-gmae"
RDEPENDS_${PN} = "\
packagegroup-core-sdk \
diff --git a/meta/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bb b/meta/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bb
index 3f322a08f6..e3b8484b74 100644
--- a/meta/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bb
+++ b/meta/recipes-gnome/packagegroups/packagegroup-core-standalone-gmae-sdk-target.bb
@@ -4,7 +4,7 @@
SUMMARY = "GNOME Mobile And Embedded SDK (target tools)"
LICENSE = "MIT"
-PR = "r15"
+PR = "r16"
inherit packagegroup
@@ -12,6 +12,8 @@ require packagegroup-sdk-gmae.inc
# For backwards compatibility after rename
RPROVIDES_${PN} = "task-core-standalone-gmae-sdk-target"
+RREPLACES_${PN} = "task-core-standalone-gmae-sdk-target"
+RCONFLICTS_${PN} = "task-core-standalone-gmae-sdk-target"
RDEPENDS_${PN} = "\
packagegroup-core-standalone-sdk-target \