aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk+
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-12-17 14:32:43 +0200
committerSaul Wold <sgw@linux.intel.com>2012-12-18 23:48:22 -0800
commit6665a41c6506039e6ba6cfdbaa941369e42d682f (patch)
tree207783aa7ef1da75da29d03e7a0a870e2549d6a6 /meta/recipes-gnome/gtk+
parentbba414bc9d14eb2d29b54c68259d13ddbe6567fa (diff)
downloadopenembedded-core-6665a41c6506039e6ba6cfdbaa941369e42d682f.tar.gz
gtk+-native: add gtk-update-icon-cache wrapper
This is needed in order to point where the pixbuf loaders.cache is located and avoid warnings like the one below that appear when the sstate is fetched from a remote machine: (gtk-update-icon-cache:8913): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/REMOTE/MACHINE/PATH/loaders.cache': No such file or directory Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-gnome/gtk+')
-rw-r--r--meta/recipes-gnome/gtk+/gtk+_2.24.14.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk+/gtk+_2.24.14.bb b/meta/recipes-gnome/gtk+/gtk+_2.24.14.bb
index 465f2b7f6a..553196a150 100644
--- a/meta/recipes-gnome/gtk+/gtk+_2.24.14.bb
+++ b/meta/recipes-gnome/gtk+/gtk+_2.24.14.bb
@@ -42,6 +42,11 @@ BBCLASSEXTEND = "native"
RRECOMMENDS_${PN}_class-native = ""
DEPENDS_class-native = "glib-2.0-native atk-native pango-native cairo-native gdk-pixbuf-native"
+do_install_append_class-native () {
+ create_wrapper ${D}/${bindir}/gtk-update-icon-cache \
+ GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
+}
+
python populate_packages_prepend () {
prologue = d.getVar("postinst_prologue", True)