aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-11-19 19:24:37 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 10:25:35 +0000
commitdeb39ecfbec9de5aaff43de4eb831c4633ffcd86 (patch)
tree4e965e8e71332c2c732db73c2425b11a67153788 /meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb
parentcbd12b46986d31141d33fa790eb3810143a192ab (diff)
downloadopenembedded-core-deb39ecfbec9de5aaff43de4eb831c4633ffcd86.tar.gz
gnome-keyring: Update to 2.32.1
Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb')
-rw-r--r--meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb b/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb
new file mode 100644
index 0000000000..1826a7ac3a
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Password and keyring managing daemon"
+HOMEPAGE = "http://www.gnome.org/"
+BUGTRACKER = "https://bugzilla.gnome.org/"
+
+LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://gcr/gcr.h;endline=22;md5=a272df1e633e27ecf35e74fb5576250e \
+ file://egg/egg-dbus.h;endline=25;md5=eb6f531af37165dc53420c073d774e61 \
+ file://gp11/gp11.h;endline=24;md5=bd8c7a8a21d6c28d40536d96a35e3469 \
+ file://pkcs11/pkcs11i.h;endline=24;md5=e72cfbb718389b76a4dae838d1c1f439"
+
+SECTION = "x11/gnome"
+
+PR = "r0"
+
+inherit autotools gnome pkgconfig
+
+DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf"
+RDEPENDS = "libgnome-keyring"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+SRC_URI += "file://org.gnome.keyring.service"
+
+do_install_append () {
+ install -d ${D}${datadir}/dbus-1/services
+ install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services"
+FILES_${PN}-dbg += "${libdir}/gnome-keyring/standalone/.debug/"
+FILES_${PN}-dbg += "${libdir}/gnome-keyring/devel/.debug/"