aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gnome-doc-utils
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-07-18 08:14:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-21 10:44:48 +0100
commitcf2fae0ea64ad1b24cbd50545ffffa80e3ef8510 (patch)
treef07b4146001c0eb0cfdae53f9d1ce634dd0b2450 /meta/recipes-gnome/gnome/gnome-doc-utils
parent339d039a9b2f0e97f25781ccf6937f1050d83989 (diff)
downloadopenembedded-core-cf2fae0ea64ad1b24cbd50545ffffa80e3ef8510.tar.gz
gnome-doc-utils: Use /usr/bin/env python in xml2po, bump PR
In oe.dev we can just sed over the binary but in newer versions of this program we need to fix the in use copy too. As noted in the patch header, this isn't appropriate for upstream as it could change behavior on Windows. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'meta/recipes-gnome/gnome/gnome-doc-utils')
-rw-r--r--meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch b/meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch
new file mode 100644
index 0000000000..a285ad2789
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gnome-doc-utils/use-usr-bin-env-for-python-in-xml2po.patch
@@ -0,0 +1,33 @@
+Upstream-Status="Inappropriate [Would break behavior on Windows]"
+
+We can't use #!/full/path/to/python -u as this can be longer than shebang
+allows for. In order to be appropraite for upstream more work would be
+needed to make sure that the main xml2po code doesn't rely on python
+being invoked with -u (force stdin/out/err to be used raw).
+---
+ xml2po/xml2po/Makefile.am | 1 -
+ xml2po/xml2po/xml2po.py.in | 2 +-
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+Index: gnome-doc-utils-0.20.6/xml2po/xml2po/Makefile.am
+===================================================================
+--- gnome-doc-utils-0.20.6.orig/xml2po/xml2po/Makefile.am
++++ gnome-doc-utils-0.20.6/xml2po/xml2po/Makefile.am
+@@ -7,7 +7,6 @@ CLEANFILES = xml2po
+
+ xml2po: xml2po.py.in
+ sed -e "s/^VERSION =.*/VERSION = \"@VERSION@\"/" \
+- -e "s+^#!.*python.*+#!$(PYTHON)+" \
+ < $(srcdir)/xml2po.py.in > xml2po
+ chmod +x xml2po
+
+Index: gnome-doc-utils-0.20.6/xml2po/xml2po/xml2po.py.in
+===================================================================
+--- gnome-doc-utils-0.20.6.orig/xml2po/xml2po/xml2po.py.in
++++ gnome-doc-utils-0.20.6/xml2po/xml2po/xml2po.py.in
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python -u
++#!/usr/bin/env python
+ # -*- encoding: utf-8 -*-
+ # Copyright (c) 2004, 2005, 2006 Danilo Ĺ egan <danilo@gnome.org>.
+ # Copyright (c) 2009 Claude Paroz <claude@2xlibre.net>.