summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-05 23:20:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-06 22:34:13 +0000
commit636f4d1f6ed8a95e3a583abc5904ab8dbc6184af (patch)
tree77895612be66206240e68520c707a09efd81e52a /meta/recipes-extended
parent6db24928d62aeb093a0e6da6619713eaca57a96f (diff)
downloadopenembedded-core-636f4d1f6ed8a95e3a583abc5904ab8dbc6184af.tar.gz
ltp: Fix another determinism issue
After the other fixes there remained occasional problems. Fix another makefile sorting problem affecting the disktest binary. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/ltp/ltp/determinism2.patch24
-rw-r--r--meta/recipes-extended/ltp/ltp_20210121.bb5
2 files changed, 27 insertions, 2 deletions
diff --git a/meta/recipes-extended/ltp/ltp/determinism2.patch b/meta/recipes-extended/ltp/ltp/determinism2.patch
new file mode 100644
index 0000000000..ab08e8e517
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/determinism2.patch
@@ -0,0 +1,24 @@
+testcases/kernel/io/disktest: Fix determinism issue
+
+The order of the objects linked into the test varies depending on the
+order of the files found on disk. This results in the disktest binary
+differing depending on that order.
+
+Sort the wildcard expansion of *.c which leads to reproducible binaries.
+
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+Upstream-Status: Pending
+
+Index: git/testcases/kernel/io/disktest/Makefile
+===================================================================
+--- git.orig/testcases/kernel/io/disktest/Makefile
++++ git/testcases/kernel/io/disktest/Makefile
+@@ -209,7 +209,7 @@ LDLIBS += -lpthread
+
+ MAKE_TARGETS := disktest
+
+-OBJS := $(patsubst $(abs_srcdir)/%.c,%.o,$(wildcard $(abs_srcdir)/*.c))
++OBJS := $(patsubst $(abs_srcdir)/%.c,%.o,$(sort $(wildcard $(abs_srcdir)/*.c)))
+
+ disktest-$(VER):
+ mkdir -p "$@"
diff --git a/meta/recipes-extended/ltp/ltp_20210121.bb b/meta/recipes-extended/ltp/ltp_20210121.bb
index 593f07087c..325574a50e 100644
--- a/meta/recipes-extended/ltp/ltp_20210121.bb
+++ b/meta/recipes-extended/ltp/ltp_20210121.bb
@@ -30,8 +30,8 @@ CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
SRCREV = "4d005621edd109d119627eb9210b224a63bf22cb"
# remove at next version upgrade or when output changes
-PR = "r1"
-HASHEQUIV_HASH_VERSION .= ".1"
+PR = "r2"
+HASHEQUIV_HASH_VERSION .= ".2"
SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://0001-build-Add-option-to-select-libc-implementation.patch \
@@ -39,6 +39,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://0001-Add-more-musl-exclusions.patch \
file://0001-Remove-OOM-tests-from-runtest-mm.patch \
file://determinism.patch \
+ file://determinism2.patch \
"
S = "${WORKDIR}/git"