aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2013-07-26 20:09:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-31 06:56:27 +0100
commit8d509edcd874e8d43b6fb6c4701c450edbbdef87 (patch)
treed49eee2a93a1b45b7bb814052371cf1ae994546f /meta/recipes-extended
parent6190c69a9f78aeef951c39e4c8700e945bbec5f7 (diff)
downloadopenembedded-core-8d509edcd874e8d43b6fb6c4701c450edbbdef87.tar.gz
shadow: use u-a for su
Use alternatives mechanism to prevent confliction of attempted installing su binary among busybox, shadow and util-linux. [YOCTO #4926] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/shadow/shadow_4.1.4.3.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/shadow/shadow_4.1.4.3.bb b/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
index caf24c06af..173da3b0f0 100644
--- a/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
+++ b/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
@@ -119,11 +119,12 @@ inherit update-alternatives
ALTERNATIVE_PRIORITY = "200"
-ALTERNATIVE_${PN} = "passwd chfn newgrp chsh groups chpasswd login vipw vigr"
+ALTERNATIVE_${PN} = "passwd chfn newgrp chsh groups chpasswd login vipw vigr su"
ALTERNATIVE_LINK_NAME[chpasswd] = "${sbindir}/chpasswd"
ALTERNATIVE_LINK_NAME[login] = "${base_bindir}/login"
ALTERNATIVE_LINK_NAME[vipw] = "${base_sbindir}/vipw"
ALTERNATIVE_LINK_NAME[vigr] = "${base_sbindir}/vigr"
+ALTERNATIVE_LINK_NAME[su] = "${bindir}/su"
pkg_postinst_${PN} () {
if [ "x$D" != "x" ]; then