aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/shadow
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-07-23 14:37:16 -0300
committerScott Garman <scott.a.garman@intel.com>2012-08-08 11:03:09 -0700
commit42e9f988bc691ca763d5eda3537d6281b7902794 (patch)
treea25a70a273e7e4b0309e4acd7eecc9721478719b /meta/recipes-extended/shadow
parentad78441045183277a7e77341f4af6d9d65a4a3c8 (diff)
downloadopenembedded-core-42e9f988bc691ca763d5eda3537d6281b7902794.tar.gz
shadow-native: use 'users' group by default
The rootfs has 'users' group at number 100 and without this fix it would assign to a non-existent group and if a group with gid as 1000 is created later it would own all files for users created. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Saul Wold <sgw@linux.intel.com> Reworked commit to fix merge conflicts with denzil branch. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-extended/shadow')
-rw-r--r--meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb b/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
index 38bb922282..529f90a071 100644
--- a/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
+++ b/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
@@ -7,7 +7,7 @@ LICENSE = "BSD | Artistic-1.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=08c553a87d4e51bbed50b20e0adcaede \
file://src/passwd.c;firstline=8;endline=30;md5=2899a045e90511d0e043b85a7db7e2fe"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://pkg-shadow.alioth.debian.org/releases/${BPN}-${PV}.tar.bz2 \
file://shadow.automake-1.11.patch \
@@ -44,6 +44,9 @@ do_install_append() {
sed -i 's:/bin/bash:/bin/sh:g' ${D}${sysconfdir}/default/useradd
sed -i '/^CREATE_MAIL_SPOOL/ s:^:#:' ${D}${sysconfdir}/default/useradd
+ # Use users group by default
+ sed -i 's,^GROUP=1000,GROUP=100,g' ${D}${sysconfdir}/default/useradd
+
install -d ${D}${sbindir} ${D}${base_sbindir} ${D}${base_bindir}
for i in passwd chfn newgrp chsh ; do
mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}