aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sat-solver/sat-solver/cmake.patch
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-03-16 17:15:09 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-17 00:08:22 +0000
commit89a5ad96eef411dccea817a6c37cb1e24840fdc1 (patch)
tree0168419b4f3cdcdd434b1614c7a6775933029e99 /meta/recipes-extended/sat-solver/sat-solver/cmake.patch
parent238a4eb4f4a60e0e0b8d675bb547a423b9a80c9f (diff)
downloadopenembedded-core-89a5ad96eef411dccea817a6c37cb1e24840fdc1.tar.gz
sat-solver: Fix solution DB generation and general cleanup
Uprev sat-solver to the latest git version. This corrects the solv db generation with RPM5. Refactor the patches for RPM5 support, cleaning up components of the cmake.patch for submission upstream. (Also fix a problem remaining in the upstream with a mismatched function name.) Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-extended/sat-solver/sat-solver/cmake.patch')
-rw-r--r--meta/recipes-extended/sat-solver/sat-solver/cmake.patch58
1 files changed, 7 insertions, 51 deletions
diff --git a/meta/recipes-extended/sat-solver/sat-solver/cmake.patch b/meta/recipes-extended/sat-solver/sat-solver/cmake.patch
index 854bd40d75..52319f0e4f 100644
--- a/meta/recipes-extended/sat-solver/sat-solver/cmake.patch
+++ b/meta/recipes-extended/sat-solver/sat-solver/cmake.patch
@@ -1,59 +1,15 @@
-check rpm
+Enable debugging for all builds
not building docs (need oxygen)
8/19/2010 - created by Qing He <qing.he@intel.com>
1/24/2011 - Disable Fedora/Debian checking/settings by Mark Hatle <mark.hatle@windriver.com>
3/15/2011 - Updated to newer version of sat-solver by Mark Hatle <mark.hatle@windriver.com>
+3/16/2011 - Split original patch and simplify by Mark Hatle <mark.hatle@windriver.com>
-diff -ur git.orig/CMakeLists.txt git/CMakeLists.txt
---- git.orig/CMakeLists.txt 2011-03-15 17:14:22.000000000 -0500
-+++ git/CMakeLists.txt 2011-03-15 17:20:09.648880770 -0500
-@@ -35,22 +35,15 @@
- FIND_PACKAGE(Check REQUIRED)
- FIND_PACKAGE(ZLIB REQUIRED)
-
--IF ( FEDORA )
--MESSAGE(STATUS "Building for Fedora")
--ADD_DEFINITIONS( -DFEDORA )
--ENDIF ( FEDORA)
--
--IF ( DEBIAN )
--MESSAGE(STATUS "Building for Debian")
--ADD_DEFINITIONS( -DDEBIAN -DDEBIAN_SEMANTICS)
--ENDIF ( DEBIAN )
--
- IF ( MULTI_SEMANTICS )
- MESSAGE(STATUS "Enabling multi dist support")
- ADD_DEFINITIONS( -DMULTI_SEMANTICS)
- ENDIF ( MULTI_SEMANTICS )
-
--IF ( NOT DEBIAN )
-+FIND_PACKAGE(PkgConfig REQUIRED)
-+PKG_CHECK_MODULES(RPM REQUIRED rpm)
-+INCLUDE_DIRECTORIES( ${RPM_INCLUDE_DIRS} )
-+
- FIND_LIBRARY(RPMDB_LIBRARY NAMES rpmdb)
- IF ( NOT RPMDB_LIBRARY )
- FIND_LIBRARY(RPMDB_LIBRARY NAMES rpm)
-@@ -59,13 +52,14 @@
- IF ( RPMIO_LIBRARY )
- SET( RPMDB_LIBRARY ${RPMIO_LIBRARY} ${RPMDB_LIBRARY} )
- ENDIF ( RPMIO_LIBRARY )
--IF ( FEDORA )
-+FIND_LIBRARY(RPMMISC_LIBRARY NAMES rpmmisc)
-+IF ( RPMMISC_LIBRARY )
-+SET( RPMDB_LIBRARY ${RPMMISC_LIBRARY} ${RPMDB_LIBRARY} )
-+ENDIF ( RPMMISC_LIBRARY )
- FIND_LIBRARY(DB_LIBRARY NAMES db)
- IF ( DB_LIBRARY )
- SET( RPMDB_LIBRARY ${DB_LIBRARY} ${RPMDB_LIBRARY} )
- ENDIF ( DB_LIBRARY )
--ENDIF ( FEDORA )
--ENDIF ( NOT DEBIAN )
-
- INCLUDE ( CheckFunctionExists )
- INCLUDE ( TestBigEndian )
-@@ -164,7 +158,7 @@
+diff -ur git.orig2/CMakeLists.txt git/CMakeLists.txt
+--- git.orig2/CMakeLists.txt 2011-03-16 16:29:43.532032285 -0500
++++ git/CMakeLists.txt 2011-03-16 16:32:59.982034501 -0500
+@@ -177,7 +177,7 @@
MESSAGE(STATUS "Looking modules in ${CMAKE_MODULE_PATH}")
@@ -62,7 +18,7 @@ diff -ur git.orig/CMakeLists.txt git/CMakeLists.txt
set ( CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS} -g -O3" )
set ( CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS} -g3 -O0" )
-@@ -173,7 +167,7 @@
+@@ -186,7 +186,7 @@
ADD_SUBDIRECTORY(tools)
ADD_SUBDIRECTORY(tests)
ADD_SUBDIRECTORY(examples)