summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
diff options
context:
space:
mode:
authorRicardo Ribalda Delgado <ricardo@ribalda.com>2019-07-23 14:37:50 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-21 21:50:32 +0100
commit5e9185d34b3a45aadec96273a0570ec5f05f6aec (patch)
treec73ef37e68ef3db2c915943dab4cec57d93192ad /meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
parent65e7f371f19e053d0bac7771a80615f6bada74c7 (diff)
downloadopenembedded-core-5e9185d34b3a45aadec96273a0570ec5f05f6aec.tar.gz
packagegroup-core-base-utils: Make it machine specific
Recipe makes use of the variable MACHINE_FEATURES, which is machine specific: ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "kbd", "", d)} This patch avoids multiconfig errors such as: ERROR: mc:qt5222:packagegroup-core-base-utils-1.0-r0 do_package_qa_setscene: Error executing a python function in exec_python_func() autogenerated: The stack trace of python calls that resulted in this exception/failure was: File: 'exec_python_func() autogenerated', lineno: 2, function: <module> 0001: *** 0002:do_package_qa_setscene(d) 0003: File: '/workdir/repo/poky/meta/classes/insane.bbclass', lineno: 1026, function: do_package_qa_setscene 1022:SSTATETASKS += "do_package_qa" 1023:do_package_qa[sstate-inputdirs] = "" 1024:do_package_qa[sstate-outputdirs] = "" 1025:python do_package_qa_setscene () { *** 1026: sstate_setscene(d) 1027:} 1028:addtask do_package_qa_setscene 1029: 1030:python do_qa_staging() { (From OE-Core rev: 70234797b973046a6198bea684bdb757def2dce1) Signed-off-by: Ricardo Ribalda Delgado <ricardo@ribalda.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb')
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb b/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
index 18e227144a..7501837937 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
@@ -11,6 +11,8 @@ inherit packagegroup
VIRTUAL-RUNTIME_vim ?= "vim-tiny"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
RDEPENDS_${PN} = "\
base-passwd \
bash \