summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/files
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-12-12 18:48:07 +0800
committerSaul Wold <sgw@linux.intel.com>2012-12-14 15:17:19 -0800
commitaa591ecb1aac1c0308c05dbac81bc056869a2c3e (patch)
tree3367aed94d63918a1c525bdd5f2c6e8db50b9d28 /meta/recipes-extended/newt/files
parent77092eeaadfd89375a6aea6d170664f4d3e6f6dd (diff)
downloadopenembedded-core-aa591ecb1aac1c0308c05dbac81bc056869a2c3e.tar.gz
newt: enable python support
Compile newt with python support. There may be packages that need newt's python extension. Add python to DEPENDS. And add patch fix_python_fpic.patch to compile python .so module with flag -fPIC. Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/newt/files')
-rw-r--r--meta/recipes-extended/newt/files/fix_python_fpic.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/files/fix_python_fpic.patch b/meta/recipes-extended/newt/files/fix_python_fpic.patch
new file mode 100644
index 0000000000..3ef94e0c56
--- /dev/null
+++ b/meta/recipes-extended/newt/files/fix_python_fpic.patch
@@ -0,0 +1,24 @@
+Fix relocations warning when compile python module
+
+After enable python support in newt, bitbake complains warning:
+
+WARNING: QA Issue: ELF binary '/mnt/sda10/poky-all-platform/build/tmp/work/i586-poky-linux/libnewt/0.52.14-r2/packages-split/libnewt-python/usr/lib/python2.7/site-packages/_snackmodule.so' has relocations in .text
+
+Add flag -fPIC to compile _snackmodule.so to fix the warning.
+
+Signed-off-by: Kang Kai <kai.kang@windriver.com>
+
+Upstream-Status: Pending
+
+---
+--- newt-0.52.14/Makefile.in 2012-12-04 17:27:27.578915801 +0800
++++ newt-0.52.14/Makefile.in.new 2012-12-04 17:28:43.274918472 +0800
+@@ -84,7 +84,7 @@
+ PIFLAGS=`$$ver-config --includes`; \
+ PLDFLAGS=`$$ver-config --ldflags`; \
+ PLFLAGS=`$$ver-config --libs`; \
+- $(CC) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c ;\
++ $(CC) $(SHCFLAGS) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c ;\
+ $(CC) --shared $$PLDFLAGS $$PLFLAGS $(LDFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L. -lnewt $(LIBS);\
+ done || :
+ touch $@