summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb
diff options
context:
space:
mode:
authorSinan Kaya <okaya@kernel.org>2020-12-16 22:48:37 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-12 17:43:05 +0000
commit05b9cdd66ad29d67bd7c3c7e968b1c102479af47 (patch)
tree31f5618323a6656e0245ade0d6c2481cbca44a9e /meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb
parent28809742c517a8e3589b9cd22ce8e82b1a983683 (diff)
downloadopenembedded-core-05b9cdd66ad29d67bd7c3c7e968b1c102479af47.tar.gz
net-tools: split mii-tool into its own package
Move the mii-tool into its own package. Useful for size constrained systems that only want the mii-tool only. Signed-off-by: Sinan Kaya <okaya@kernel.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb')
-rw-r--r--meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb b/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb
index dcc2218e48..e163a6948a 100644
--- a/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb
+++ b/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb
@@ -105,4 +105,18 @@ python __anonymous() {
}
ALTERNATIVE_PRIORITY = "100"
-BBCLASSEXTEND = "native nativesdk"
+NETTOOLS_PACKAGES = "${PN}-mii-tool"
+NETTOOLS_PACKAGES_class-native = ""
+
+PACKAGE_BEFORE_PN = "${NETTOOLS_PACKAGES}"
+RDEPENDS_${PN} += "${NETTOOLS_PACKAGES}"
+
+FILES_${PN}-mii-tool = "${base_sbindir}/mii-tool"
+
+ALTERNATIVE_${PN}_remove = "mii-tool"
+
+ALTERNATIVE_${PN}-mii-tool = "mii-tool"
+ALTERNATIVE_TARGET[mii-tool] = "${base_sbindir}/mii-tool"
+ALTERNATIVE_LINK_NAME[mii-tool] = "${base_sbindir}/mii-tool"
+
+BBCLASSEXTEND = "native nativesdk" \ No newline at end of file