aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2013-11-12 11:40:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-20 14:02:52 +0000
commitd3caab6eb03264b4f4d744f914598022299011ba (patch)
tree7e304c1174b99d700ec9af32f1f4f1b8baecc89c /meta/recipes-extended/mdadm
parent53d342db9f9995564573715f28c3e4c9c8c68bf9 (diff)
downloadopenembedded-core-d3caab6eb03264b4f4d744f914598022299011ba.tar.gz
mdadm: flag __SANE_USERSPACE_TYPES__ to include int-ll64.h for powerpc64
*PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h prevents 64-bit userland from seeing this definition, instead defaulting to u64 == long in userspace. *fix the below error |super-ddf.c:4542:5: error: format '%llu' expects argument of type 'long long unsigned int', |but argument 5 has type '__u64' [-Werror=format=] |dprintf("BVD %u has %08x at %llu\n", 0, Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/mdadm')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.3.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.3.bb b/meta/recipes-extended/mdadm/mdadm_3.3.bb
index 586e04aa5a..41816bc414 100644
--- a/meta/recipes-extended/mdadm/mdadm_3.3.bb
+++ b/meta/recipes-extended/mdadm/mdadm_3.3.bb
@@ -26,6 +26,11 @@ do_configure_prepend () {
}
EXTRA_OEMAKE = "CHECK_RUN_DIR=0"
+# PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h
+# prevents 64-bit userland from seeing this definition, instead defaulting
+# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
+# int-ll64.h included
+EXTRA_OEMAKE_append_powerpc64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
do_compile() {
oe_runmake