aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-01-26 17:14:54 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-02 11:21:55 +0000
commit97bc0d1575b08830e3953933cbbc5732b1a82b31 (patch)
tree8f179af00a8655add0ad610c3ff78c6d6c433771 /meta/recipes-extended/mdadm
parentc9036a6d2ba4a246ec7216be1971de7eb91aad5f (diff)
downloadopenembedded-core-97bc0d1575b08830e3953933cbbc5732b1a82b31.tar.gz
mdadm: fix build on qemumips64
The mips64 uses long long for u64 in the kernel, but powerpc's asm/types.h prevents 64-bit userland from seeing this definition, instead defaulting to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get int-ll64.h included. We had a similar fix on ppc64, use it for mips64 will fix the problem. [YOCTO #5758] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/mdadm')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.3.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.3.bb b/meta/recipes-extended/mdadm/mdadm_3.3.bb
index cfb9ccd5c3..596b04ded8 100644
--- a/meta/recipes-extended/mdadm/mdadm_3.3.bb
+++ b/meta/recipes-extended/mdadm/mdadm_3.3.bb
@@ -25,11 +25,12 @@ do_configure_prepend () {
}
EXTRA_OEMAKE = "CHECK_RUN_DIR=0"
-# PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h
+# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h
# prevents 64-bit userland from seeing this definition, instead defaulting
# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
# int-ll64.h included
EXTRA_OEMAKE_append_powerpc64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
+EXTRA_OEMAKE_append_mips64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
do_compile() {
oe_runmake