aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2011-10-05 17:13:08 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-10 09:54:03 +0100
commit1325f506972555d4c218c15090bfa3f63fb13473 (patch)
tree17b61ade7926890848578fea41f4a5526851b12b /meta/recipes-extended/mdadm
parent30e8ceb8d78d9dd0a381dd4e47da2ec6c449beaf (diff)
downloadopenembedded-core-1325f506972555d4c218c15090bfa3f63fb13473.tar.gz
Fix mdadm for powerpc64
This takes an upstream fix for compiling on powerpc64 Signed-off-by: Matthew McClintock <msm@freescale.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm')
-rw-r--r--meta/recipes-extended/mdadm/files/0001-mdadm-fix-build-failures-ppc64.patch50
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.2.2.bb6
2 files changed, 54 insertions, 2 deletions
diff --git a/meta/recipes-extended/mdadm/files/0001-mdadm-fix-build-failures-ppc64.patch b/meta/recipes-extended/mdadm/files/0001-mdadm-fix-build-failures-ppc64.patch
new file mode 100644
index 0000000000..931ecbc16d
--- /dev/null
+++ b/meta/recipes-extended/mdadm/files/0001-mdadm-fix-build-failures-ppc64.patch
@@ -0,0 +1,50 @@
+From 19986c721c9ac4b353c8592998d70d0dc8860bfd Mon Sep 17 00:00:00 2001
+From: Milan Broz <mbroz@redhat.com>
+Date: Thu, 14 Jul 2011 13:58:36 +1000
+Subject: [PATCH] mdadm: fix build failures (ppc64)
+
+This patch fixes these build issues:
+
+super-intel.c: In function 'getinfo_super_imsm_volume':
+super-intel.c:2327:4: error: format '%llu' expects argument of type 'long long
+unsigned int', but argument 3 has type '__u64' [-Werror=format]
+
+super-intel.c: In function 'imsm_reshape_super':
+super-intel.c:8665:7: error: 'devnum' may be used uninitialized in this function [-Werror=uninitialized]
+
+Signed-off-by: Milan Broz <mbroz@redhat.com>
+Signed-off-by: NeilBrown <neilb@suse.de>
+---
+ super-intel.c | 9 ++++++---
+ 1 files changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/super-intel.c b/super-intel.c
+index 5ea3b36..70cf993 100644
+--- a/super-intel.c
++++ b/super-intel.c
+@@ -2326,7 +2326,9 @@ static void getinfo_super_imsm_volume(struct supertype *st, struct mdinfo *info,
+
+ dprintf("IMSM: General Migration checkpoint : %llu "
+ "(%llu) -> read reshape progress : %llu\n",
+- units, blocks_per_unit, info->reshape_progress);
++ (unsigned long long)units,
++ (unsigned long long)blocks_per_unit,
++ info->reshape_progress);
+
+ used_disks = imsm_num_data_members(dev, 1);
+ if (used_disks > 0) {
+@@ -8661,8 +8663,9 @@ static int imsm_reshape_super(struct supertype *st, long long size, int level,
+ dprintf("imsm: info: Volume operation\n");
+ /* find requested device */
+ while (dev) {
+- imsm_find_array_minor_by_subdev(dev->index, st->container_dev, &devnum);
+- if (devnum == geo.dev_id)
++ if (imsm_find_array_minor_by_subdev(
++ dev->index, st->container_dev, &devnum) == 0
++ && devnum == geo.dev_id)
+ break;
+ dev = dev->next;
+ }
+--
+1.7.6.1
+
diff --git a/meta/recipes-extended/mdadm/mdadm_3.2.2.bb b/meta/recipes-extended/mdadm/mdadm_3.2.2.bb
index 5d29ae781f..492cc8e6f7 100644
--- a/meta/recipes-extended/mdadm/mdadm_3.2.2.bb
+++ b/meta/recipes-extended/mdadm/mdadm_3.2.2.bb
@@ -8,9 +8,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
-PR = "r0"
+PR = "r1"
-SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.bz2"
+SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.bz2 \
+ file://0001-mdadm-fix-build-failures-ppc64.patch \
+ "
SRC_URI[md5sum] = "12ee2fbf3beddb60601fb7a4c4905651"
SRC_URI[sha256sum] = "0d1a04e688b082bc88846e3f524abd50bc782b6ffc06123140f7d358c8f9b906"