aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd
diff options
context:
space:
mode:
authorYasir-Khan <yasir_khan@mentor.com>2014-01-06 21:43:33 +0500
committerSaul Wold <sgw@linux.intel.com>2014-01-08 22:54:54 -0800
commitcd97c2b77e32ec741aa5a51e1e1799b7665a184d (patch)
tree707d49d12fc522202f90693a255bd0056a28e6cd /meta/recipes-extended/lighttpd
parentf3fd24badd189bbb083dba9397598e1566d1e4be (diff)
downloadopenembedded-core-cd97c2b77e32ec741aa5a51e1e1799b7665a184d.tar.gz
lighttpd: add www/{logs,var} symlinks
For FHS compliance, create symbolic links to write variable data to standard paths Signed-off-by: Yasir-Khan <yasir_khan@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/lighttpd')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb
index 528fda7791..2ddab16498 100644
--- a/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb
@@ -47,7 +47,7 @@ INITSCRIPT_PARAMS = "defaults 70"
SYSTEMD_SERVICE_${PN} = "lighttpd.service"
do_install_append() {
- install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
+ install -d ${D}${sysconfdir}/init.d ${D}/www/pages/dav
install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
@@ -58,6 +58,9 @@ do_install_append() {
-e 's,@SYSCONFDIR@,${sysconfdir},g' \
-e 's,@BASE_BINDIR@,${base_bindir},g' \
${D}${systemd_unitdir}/system/lighttpd.service
+ #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
+ ln -sf ${localstatedir}/log ${D}/www/logs
+ ln -sf ${localstatedir}/tmp ${D}/www/var
}
FILES_${PN} += "${sysconfdir} /www"