aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/acpica/files
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2017-01-10 15:55:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-23 15:11:22 -0800
commit020f7ea3aa5c1f311841d4fb16bc525ae1dd5f11 (patch)
tree05e437dd481d5665ad6663f49ab5e56c3713a764 /meta/recipes-extended/acpica/files
parent1264d26fa251ac11a9069f3e602dec6be9d8b9ba (diff)
downloadopenembedded-core-020f7ea3aa5c1f311841d4fb16bc525ae1dd5f11.tar.gz
acpica: move from meta-oe to OE-core
qemu support for UEFI in OE-core depends on OVMF, which needs the iasl tools provided by this recipe. There's also an iasl recipe in meta-luv, but than can and will be replaced by this one, thus reducing overall maintenance work. Copied from meta-openembedded rev fa65be9ba (current master). Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
Diffstat (limited to 'meta/recipes-extended/acpica/files')
-rw-r--r--meta/recipes-extended/acpica/files/no-werror.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/files/no-werror.patch b/meta/recipes-extended/acpica/files/no-werror.patch
new file mode 100644
index 0000000000..5d28f474f2
--- /dev/null
+++ b/meta/recipes-extended/acpica/files/no-werror.patch
@@ -0,0 +1,32 @@
+Description: remove -Werror flag
+Forwarded: not-needed
+Author: Fathi Boudra <fathi.boudra@linaro.org>
+
+---
+ generate/unix/iasl/Makefile | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+--- a/generate/unix/iasl/Makefile
++++ b/generate/unix/iasl/Makefile
+@@ -266,19 +266,19 @@ $(OBJDIR)/prparser.y.h: $(OBJDIR)/prpars
+ # by the utilities above and they are not necessarily ANSI C, etc.
+ #
+ $(OBJDIR)/aslcompilerlex.o : $(OBJDIR)/aslcompilerlex.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
++ $(CC) -c $(CFLAGS) -Wall -o$@ $<
+
+ $(OBJDIR)/aslcompilerparse.o : $(OBJDIR)/aslcompilerparse.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
++ $(CC) -c $(CFLAGS) -Wall -o$@ $<
+
+ $(OBJDIR)/dtparserlex.o : $(OBJDIR)/dtparserlex.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
++ $(CC) -c $(CFLAGS) -Wall -o$@ $<
+
+ $(OBJDIR)/dtparserparse.o : $(OBJDIR)/dtparserparse.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
++ $(CC) -c $(CFLAGS) -Wall -o$@ $<
+
+ $(OBJDIR)/prparserlex.o : $(OBJDIR)/prparserlex.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
++ $(CC) -c $(CFLAGS) -Wall -o$@ $<