aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-20 21:22:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-22 18:30:06 +0100
commite7e8fe11c34bf05179f3bbaa2fb1af7b7125696a (patch)
tree1a3eabcc578fa399694cd1bcd9c9fb4b200cb1b7 /meta/recipes-devtools
parentb0d1ab6242b6ce2bcdd0e4e3e61600344fcd2907 (diff)
downloadopenembedded-core-e7e8fe11c34bf05179f3bbaa2fb1af7b7125696a.tar.gz
gcc: Drop gcc-cross4.inc, its pointless now
The include was useful historically, its not anymore so lets remove it. This should have no functional change except on any layers directly depending on it or gcc-cross.inc but even then it would only impact sh4 and is easily fixed if there was a problem. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross.inc2
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross4.inc3
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross_4.7.bb2
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross_4.8.bb2
4 files changed, 4 insertions, 5 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-cross.inc b/meta/recipes-devtools/gcc/gcc-cross.inc
index 9d29f56421..2913df79b3 100644
--- a/meta/recipes-devtools/gcc/gcc-cross.inc
+++ b/meta/recipes-devtools/gcc/gcc-cross.inc
@@ -106,3 +106,5 @@ STOP
chmod +x ${B}/${TARGET_PREFIX}testgcc
}
+
+EXTRA_OECONF_append_sh4 = " --with-multilib-list= --enable-incomplete-targets "
diff --git a/meta/recipes-devtools/gcc/gcc-cross4.inc b/meta/recipes-devtools/gcc/gcc-cross4.inc
deleted file mode 100644
index 4a20818d2f..0000000000
--- a/meta/recipes-devtools/gcc/gcc-cross4.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-require gcc-cross.inc
-
-EXTRA_OECONF_append_sh4 = " --with-multilib-list= --enable-incomplete-targets "
diff --git a/meta/recipes-devtools/gcc/gcc-cross_4.7.bb b/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
index d60523513f..b02ea13de2 100644
--- a/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
+++ b/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
@@ -1,5 +1,5 @@
require recipes-devtools/gcc/gcc-${PV}.inc
-require gcc-cross4.inc
+require gcc-cross.inc
EXTRA_OECONF += "--disable-libunwind-exceptions \
--with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
diff --git a/meta/recipes-devtools/gcc/gcc-cross_4.8.bb b/meta/recipes-devtools/gcc/gcc-cross_4.8.bb
index d60523513f..b02ea13de2 100644
--- a/meta/recipes-devtools/gcc/gcc-cross_4.8.bb
+++ b/meta/recipes-devtools/gcc/gcc-cross_4.8.bb
@@ -1,5 +1,5 @@
require recipes-devtools/gcc/gcc-${PV}.inc
-require gcc-cross4.inc
+require gcc-cross.inc
EXTRA_OECONF += "--disable-libunwind-exceptions \
--with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \