aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-22 09:31:56 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-22 18:30:06 +0100
commita77a8011e56f7cddf22adc63270aa9f44c86062a (patch)
tree223b6bf6d8338f65ccf87a65eeab4c64ad88d1d8 /meta/recipes-devtools
parenta2110e86b98d646e136de9ec6b8e668079b0d4f4 (diff)
downloadopenembedded-core-a77a8011e56f7cddf22adc63270aa9f44c86062a.tar.gz
gcc-cross: Fold common configuration into gcc-cross.inc
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross.inc12
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross_4.7.bb11
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross_4.8.bb11
3 files changed, 12 insertions, 22 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-cross.inc b/meta/recipes-devtools/gcc/gcc-cross.inc
index 2913df79b3..c3542e297c 100644
--- a/meta/recipes-devtools/gcc/gcc-cross.inc
+++ b/meta/recipes-devtools/gcc/gcc-cross.inc
@@ -108,3 +108,15 @@ STOP
}
EXTRA_OECONF_append_sh4 = " --with-multilib-list= --enable-incomplete-targets "
+
+EXTRA_OECONF += "--disable-libunwind-exceptions \
+ --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
+ --with-system-zlib "
+
+EXTRA_OECONF_PATHS = " \
+ --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
+ --with-sysroot=${STAGING_DIR_TARGET} \
+ --with-build-sysroot=${STAGING_DIR_TARGET}"
+
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/meta/recipes-devtools/gcc/gcc-cross_4.7.bb b/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
index b02ea13de2..b43cca0c52 100644
--- a/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
+++ b/meta/recipes-devtools/gcc/gcc-cross_4.7.bb
@@ -1,14 +1,3 @@
require recipes-devtools/gcc/gcc-${PV}.inc
require gcc-cross.inc
-EXTRA_OECONF += "--disable-libunwind-exceptions \
- --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
- --with-system-zlib "
-
-EXTRA_OECONF_PATHS = " \
- --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
- --with-sysroot=${STAGING_DIR_TARGET} \
- --with-build-sysroot=${STAGING_DIR_TARGET}"
-
-
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/meta/recipes-devtools/gcc/gcc-cross_4.8.bb b/meta/recipes-devtools/gcc/gcc-cross_4.8.bb
index b02ea13de2..b43cca0c52 100644
--- a/meta/recipes-devtools/gcc/gcc-cross_4.8.bb
+++ b/meta/recipes-devtools/gcc/gcc-cross_4.8.bb
@@ -1,14 +1,3 @@
require recipes-devtools/gcc/gcc-${PV}.inc
require gcc-cross.inc
-EXTRA_OECONF += "--disable-libunwind-exceptions \
- --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
- --with-system-zlib "
-
-EXTRA_OECONF_PATHS = " \
- --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
- --with-sysroot=${STAGING_DIR_TARGET} \
- --with-build-sysroot=${STAGING_DIR_TARGET}"
-
-
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"