aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-22 09:12:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-22 18:30:06 +0100
commita2110e86b98d646e136de9ec6b8e668079b0d4f4 (patch)
treebdcd5466e1fde5e922f20f1e95045a6c2147a125 /meta/recipes-devtools
parent9f19d1b90c4fa04439b6267bda0484fd0b350373 (diff)
downloadopenembedded-core-a2110e86b98d646e136de9ec6b8e668079b0d4f4.tar.gz
bitbake.conf/classes/gcc: Don't hardcode -nativesdk
Hardcoding -nativesdk as the sdk package architecture is inflexible. We may have multiple different target OS and we need a way to be able to separate them. Turning this into a configurable value allows the flexibility we need to build different SDKMACHINEs with different OS targets. The commit should have no behaviour change, just makes things more configurable. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/gcc/gcc-configure-runtime.inc8
-rw-r--r--meta/recipes-devtools/gcc/libgcc_4.7.bb6
-rw-r--r--meta/recipes-devtools/gcc/libgcc_4.8.bb6
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-configure-runtime.inc b/meta/recipes-devtools/gcc/gcc-configure-runtime.inc
index 977a98a377..f89ca6bbad 100644
--- a/meta/recipes-devtools/gcc/gcc-configure-runtime.inc
+++ b/meta/recipes-devtools/gcc/gcc-configure-runtime.inc
@@ -15,8 +15,8 @@ RUNTIMETARGET = "libssp libstdc++-v3 libgomp"
do_configure () {
export CXX="${CXX} -nostdinc++ -nostdlib++"
- mtarget=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##`
- target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
+ mtarget=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
+ target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$mtarget/* ${B}
for d in libgcc ${RUNTIMETARGET}; do
echo "Configuring $d"
@@ -29,7 +29,7 @@ do_configure () {
}
do_compile () {
- target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
+ target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
for d in libgcc ${RUNTIMETARGET}; do
cd ${B}/$target/$d/
oe_runmake MULTIBUILDTOP=${B}/$target/$d/
@@ -37,7 +37,7 @@ do_compile () {
}
do_install () {
- target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
+ target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
for d in ${RUNTIMETARGET}; do
cd ${B}/$target/$d/
oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/$d/ install
diff --git a/meta/recipes-devtools/gcc/libgcc_4.7.bb b/meta/recipes-devtools/gcc/libgcc_4.7.bb
index 47669a210c..3b5bb43c00 100644
--- a/meta/recipes-devtools/gcc/libgcc_4.7.bb
+++ b/meta/recipes-devtools/gcc/libgcc_4.7.bb
@@ -26,7 +26,7 @@ FILES_libgcov-dev = " \
FILES_${PN}-dbg += "${base_libdir}/.debug/"
do_configure () {
- target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##`
+ target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
install -d ${D}${base_libdir} ${D}${libdir}
cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B}
mkdir -p ${B}/${BPN}
@@ -36,13 +36,13 @@ do_configure () {
}
do_compile () {
- target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
+ target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
cd ${B}/${BPN}
oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/
}
do_install () {
- target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
+ target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
cd ${B}/${BPN}
oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install
diff --git a/meta/recipes-devtools/gcc/libgcc_4.8.bb b/meta/recipes-devtools/gcc/libgcc_4.8.bb
index 47669a210c..3b5bb43c00 100644
--- a/meta/recipes-devtools/gcc/libgcc_4.8.bb
+++ b/meta/recipes-devtools/gcc/libgcc_4.8.bb
@@ -26,7 +26,7 @@ FILES_libgcov-dev = " \
FILES_${PN}-dbg += "${base_libdir}/.debug/"
do_configure () {
- target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##`
+ target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
install -d ${D}${base_libdir} ${D}${libdir}
cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B}
mkdir -p ${B}/${BPN}
@@ -36,13 +36,13 @@ do_configure () {
}
do_compile () {
- target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
+ target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
cd ${B}/${BPN}
oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/
}
do_install () {
- target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
+ target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
cd ${B}/${BPN}
oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install