aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2013-08-12 19:45:48 -0500
committerSaul Wold <sgw@linux.intel.com>2013-08-22 09:15:33 -0700
commit6fd8141bbdcd84c591149d84ad84effc2357de72 (patch)
tree10ba26e88f1e2c9cd238d543d9707b6b6a74495d /meta/recipes-devtools
parent238c46c03d0d9c35523c78b94bfebb57904bac5a (diff)
downloadopenembedded-core-6fd8141bbdcd84c591149d84ad84effc2357de72.tar.gz
python-smartpm: Add support to disable installing recommends
In order to attempt to reduce image sizes by skipping recommended packages, a new mode was added to smart that only evaluates required packaged. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-smartpm/smart-config-ignore-all-recommends.patch24
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm/smart-config-ignore-all-recommends.patch b/meta/recipes-devtools/python/python-smartpm/smart-config-ignore-all-recommends.patch
new file mode 100644
index 0000000000..df9d7799e8
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smartpm/smart-config-ignore-all-recommends.patch
@@ -0,0 +1,24 @@
+Add a simple method to disable the install of recommended packages
+
+Upstream-Status: Pending
+
+Usage:
+ smart config --set ignore-all-recommends=1
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+Index: smart-1.4.1/smart/transaction.py
+===================================================================
+--- smart-1.4.1.orig/smart/transaction.py
++++ smart-1.4.1/smart/transaction.py
+@@ -611,7 +611,9 @@ class Transaction(object):
+ for prv in req.providedby:
+ for prvpkg in prv.packages:
+ if not reqrequired:
+- if pkgconf.testFlag("ignore-recommends", prvpkg):
++ if sysconf.get("ignore-all-recommends", 0) == 1:
++ continue
++ elif pkgconf.testFlag("ignore-recommends", prvpkg):
+ continue
+ if isinst(prvpkg):
+ found = True
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
index b3b471a8b1..5d673b9902 100644
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -29,6 +29,7 @@ SRC_URI = "\
file://smart-conflict-provider.patch \
file://smart-flag-ignore-recommends.patch \
file://smart-flag-exclude-packages.patch \
+ file://smart-config-ignore-all-recommends.patch \
"
SRC_URI[md5sum] = "573ef32ba177a6b3c4bf7ef04873fcb6"