diff options
author | Jason Wessel <jason.wessel@windriver.com> | 2014-02-01 08:07:39 -0600 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-02-02 10:00:24 +0000 |
commit | 9edbd9d872c128038fd7b56fac713256fd69c6c5 (patch) | |
tree | 234459caeae02cc13e2d1da3d03a6a43f744f0fd /meta/recipes-devtools/unfs3 | |
parent | 3004eb3b7ee5fd8dfe9c4e5749b4e125d0bd4b59 (diff) | |
download | openembedded-core-9edbd9d872c128038fd7b56fac713256fd69c6c5.tar.gz |
unfs3: Fix compile regression from unfs3 port
A line got dropped from the original patch when porting to the latest
unfs3. The regression was introduced in commit 7d8075c64 (unfs3: Fix
dependencies and allow target builds).
This patch restores the missing line from the original which had been
working fine for over a year's time.
--- a/Config/Makefile.in
+++ b/Config/Makefile.in
@@ -12,7 +12,9 @@ all: lib.a
lib.a: $(OBJS)
$(AR) crs lib.a $(OBJS)
-y.tab.h y.tab.c: exports.y
+y.tab.h: y.tab.c
+
+y.tab.c: exports.y
$(YACC) -d exports.y
Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/unfs3')
-rw-r--r-- | meta/recipes-devtools/unfs3/unfs3/unfs3_parallel_build.patch | 7 |
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-devtools/unfs3/unfs3/unfs3_parallel_build.patch b/meta/recipes-devtools/unfs3/unfs3/unfs3_parallel_build.patch index 67777695d5..6f64dd5b3e 100644 --- a/meta/recipes-devtools/unfs3/unfs3/unfs3_parallel_build.patch +++ b/meta/recipes-devtools/unfs3/unfs3/unfs3_parallel_build.patch @@ -7,9 +7,9 @@ Jason Wessel <jason.wessel@windriver.com> Upstream-Status: Submitted http://sourceforge.net/p/unfs3/bugs/5/ --- - Config/Makefile.in | 2 ++ + Config/Makefile.in | 3 +++ Makefile.in | 3 ++- - 2 files changed, 4 insertions(+), 1 deletion(-) + 2 files changed, 5 insertions(+), 1 deletion(-) --- a/Makefile.in +++ b/Makefile.in @@ -25,10 +25,11 @@ Upstream-Status: Submitted http://sourceforge.net/p/unfs3/bugs/5/ $(CC) -o $@ $(OBJS) $(CONFOBJ) $(EXTRAOBJ) $(LDFLAGS) --- a/Config/Makefile.in +++ b/Config/Makefile.in -@@ -16,6 +16,8 @@ lib.a: $(OBJS) +@@ -16,6 +16,9 @@ lib.a: $(OBJS) $(AR) crs lib.a $(OBJS) y.tab.h y.tab.c: $(srcdir)/exports.y ++y.tab.h: y.tab.c + +y.tab.c: $(srcdir)/exports.y $(YACC) -d $(srcdir)/exports.y |