aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/squashfs-tools
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2015-05-21 13:22:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-28 09:41:58 +0100
commit07961604732405c14a292cc963006f48a4a82bfd (patch)
tree8c0130b676feb7b738c20914034a8be8a34dc356 /meta/recipes-devtools/squashfs-tools
parent2a355d2efb44a70571586bc5f6e500fa5d73db33 (diff)
downloadopenembedded-core-07961604732405c14a292cc963006f48a4a82bfd.tar.gz
squashfs-tools: build and install unsquashfs as well
* it's useful for debugging corrupt squashfs images from mksquashfs (From OE-Core rev: af3c9bbf2db5a712f63145697d045d2f1ddce271) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/squashfs-tools')
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
index d36f0fea44..19d555e1e9 100644
--- a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb
@@ -27,11 +27,12 @@ SPDX_S = "${WORKDIR}/squashfs${PV}"
EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1 LZO_SUPPORT=1 LZ4_SUPPORT=1"
do_compile() {
- oe_runmake mksquashfs
+ oe_runmake mksquashfs unsquashfs
}
do_install () {
install -d ${D}${sbindir}
install -m 0755 mksquashfs ${D}${sbindir}/
+ install -m 0755 unsquashfs ${D}${sbindir}/
}
ARM_INSTRUCTION_SET = "arm"