summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rust
diff options
context:
space:
mode:
authorPgowda <pgowda.cve@gmail.com>2021-11-15 06:03:40 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-23 10:53:12 +0000
commitbcf48766d1123cea41f80b0cb687584692c96158 (patch)
treed8799bd019f9b241c011b0b916575251ad2e6380 /meta/recipes-devtools/rust
parent3966cbf5c8a2dbc3a4f0f3eefdbeeb83f522bf87 (diff)
downloadopenembedded-core-bcf48766d1123cea41f80b0cb687584692c96158.tar.gz
rust-cross: Replace TARGET_ARCH with TUNE_PKGARCH
rust-cross-* imported from meta-rust has incorrect signatures, depending on MACHINEOVERRIDES making it effectively MACHINE_ARCH as shown by sstate-diff-machines.sh: openembedded-core/scripts/sstate-diff-machines.sh --tmpdir=tmp-glibc \ --machines="qemuarm64 qemuarm64copy" --targets=rust-cross-aarch64-glibc \ --analyze === Comparing signatures for task do_configure.sigdata between qemuarm64 and qemuarm64copy === ERROR: gcc-runtime different signature for task do_configure.sigdata between qemuarm64 and qemuarm64copy NOTE: Starting bitbake server... Hash for dependent task gcc/gcc-runtime_11.2.bb:do_prepare_recipe_sysroot changed from da4ebf1b272cb73153145a0a95e6438d2955ae2d36f84db10f6880b2781ec331 to 47a0ebb7a88c9f896fb9dbce269f575ab8a6faabb2b9e62d164be6e71c5e4e40 Unable to find matching sigdata for openembedded-core/meta/recipes-devtools/gcc/gcc-runtime_11.2.bb: do_prepare_recipe_sysroot with hashes da4ebf1b272cb73153145a0a95e6438d2955ae2d36f84db10f6880b2781ec331 or 47a0ebb7a88c9f896fb9dbce269f575ab8a6faabb2b9e62d164be6e71c5e4e40 The following patch takes TUNE_PKGARCH into consideration instead of TARGET_ARCH and results in signatures as expected. [YOCTO #14613] RP: Added maintainer.inc corresponding change Signed-off-by: Pgowda <pgowda.cve@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rust')
-rw-r--r--meta/recipes-devtools/rust/rust-cross.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rust/rust-cross.inc b/meta/recipes-devtools/rust/rust-cross.inc
index bb625f4240..a77f7d5122 100644
--- a/meta/recipes-devtools/rust/rust-cross.inc
+++ b/meta/recipes-devtools/rust/rust-cross.inc
@@ -34,7 +34,7 @@ DEPENDS += "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}compilerlibs vir
DEPENDS += "rust-native"
PROVIDES = "virtual/${TARGET_PREFIX}rust"
-PN = "rust-cross-${TARGET_ARCH}-${TCLIBC}"
+PN = "rust-cross-${TUNE_PKGARCH}-${TCLIBC}"
# In the cross compilation case, rustc doesn't seem to get the rpath quite
# right. It manages to include '../../lib/${TARGET_PREFIX}', but doesn't