aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-01-04 14:56:44 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-06 10:11:42 +0000
commit4e09525c73348c2b47b07654ac31ffc6cbd3d5fe (patch)
treee002c60618a634491ae8efa0c82815d03fbef350 /meta/recipes-devtools/python
parent06d24d38d79bc525ac6403db9a0b057fd5f11e4a (diff)
downloadopenembedded-core-4e09525c73348c2b47b07654ac31ffc6cbd3d5fe.tar.gz
python[3]-setuptools: inherit setuptools
* distutils[3].bbclass was not including pkg_resources module * Drop uneeded DISTUTILS_INSTALL_ARGS as setuptools[3].bbclass provides it Fixes [YOCTO #12148] Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_36.2.7.bb4
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_36.2.7.bb7
2 files changed, 2 insertions, 9 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_36.2.7.bb b/meta/recipes-devtools/python/python-setuptools_36.2.7.bb
index 526474c7ea..0efacc137a 100644
--- a/meta/recipes-devtools/python/python-setuptools_36.2.7.bb
+++ b/meta/recipes-devtools/python/python-setuptools_36.2.7.bb
@@ -5,9 +5,7 @@ PROVIDES = "python-distribute"
DEPENDS += "python"
DEPENDS_class-native += "python-native"
-inherit distutils
-
-DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
+inherit setuptools
RDEPENDS_${PN} = "\
python-stringold \
diff --git a/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb b/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
index 63f241809e..a7bca97402 100644
--- a/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
@@ -4,15 +4,10 @@ DEPENDS += "python3"
DEPENDS_class-native += "python3-native"
DEPENDS_class-nativesdk += "nativesdk-python3"
-inherit distutils3
+inherit setuptools3
-DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
-
-# The installer puts the wrong path in the setuptools.pth file. Correct it.
do_install_append() {
- rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
- echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
}
RDEPENDS_${PN}_class-native = "\