aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.5.2.bb
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-02-26 08:44:45 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 15:50:19 +0000
commit800753069f667cd1664d70b3779150c467e3b3fe (patch)
treeb22bfc2150774cd6d87b8312598a71ceb397f921 /meta/recipes-devtools/python/python3-native_3.5.2.bb
parent0cb15d9559e34faffea1ac0be825d0602f225ba9 (diff)
downloadopenembedded-core-800753069f667cd1664d70b3779150c467e3b3fe.tar.gz
generate-manifest-3.5.py: add logic to generate native manifest
python3-native supposes to RPROVIDE all native packages as added in generate-manifest-3.5.py, but it does not so far, this leads a problem that sometimes bitbake cant find a runtime provider for a python3-*-native when a new runtime dependency on it being required, this usualy happens after a new native python3-* recipe is created or the old native python3-* recipes are upgraded. To avoid manually extending RPROVIDE every time when a new runtime dependency is introduced, an argument '-n/--native' is added to the manifest generator, allowing it create a native python3 manifest, with a RPROVIDE line only, the RPROVIDE should contain all the sub-packages. The generated python-native-3.5-manifest.inc is also added which is included by python3-native recipe. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.5.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.2.bb27
1 files changed, 1 insertions, 26 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.2.bb b/meta/recipes-devtools/python/python3-native_3.5.2.bb
index bf4e6860fa..edcf2244f5 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.2.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.2.bb
@@ -41,32 +41,7 @@ DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native s
inherit native
-RPROVIDES += " \
- python3-compression-native \
- python3-core-native \
- python3-distutils-native \
- python3-datetime-native \
- python3-enum-native \
- python3-terminal-native \
- python3-email-native \
- python3-importlib-native \
- python3-io-native \
- python3-json-native \
- python3-lang-native \
- python3-misc-native \
- python3-modules-native \
- python3-netclient-native \
- python3-netserver-native \
- python3-numbers-native \
- python3-pkgutil-native \
- python3-pprint-native \
- python3-re-native \
- python3-shell-native \
- python3-subprocess-native \
- python3-textutils-native \
- python3-threading-native \
- python3-unittest-native \
-"
+require python-native-${PYTHON_MAJMIN}-manifest.inc
EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip"