aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-nose_1.3.7.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-01-19 21:56:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:37 +0000
commit9f6942524b1b1bf028f4176e4549acd583a69762 (patch)
tree0f1f9e49316b0a284de447efe2be5685b50c3a7b /meta/recipes-devtools/python/python-nose_1.3.7.bb
parent4583cd1bb15306e8f0ab7bcd80732e6f35aa4533 (diff)
downloadopenembedded-core-9f6942524b1b1bf028f4176e4549acd583a69762.tar.gz
python-nose: upgrade to 1.3.7
Updates runtime dependencies, python-nose now depends on unittest. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-nose_1.3.7.bb')
-rw-r--r--meta/recipes-devtools/python/python-nose_1.3.7.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-nose_1.3.7.bb b/meta/recipes-devtools/python/python-nose_1.3.7.bb
new file mode 100644
index 0000000000..ec6158fab1
--- /dev/null
+++ b/meta/recipes-devtools/python/python-nose_1.3.7.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Extends Python unittest to make testing easier"
+DESCRIPTION = "nose extends the test loading and running features of unittest, \
+making it easier to write, find and run tests."
+SECTION = "devel/python"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://lgpl.txt;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+SRC_URI = "http://pypi.python.org/packages/source/n/nose/nose-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "4d3ad0ff07b61373d2cefc89c5d0b20b"
+SRC_URI[sha256sum] = "f1bffef9cbc82628f6e7d7b40d7e255aefaa1adb6a1b1d26c69a8b79e6208a98"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/nose/"
+UPSTREAM_CHECK_REGEX = "/nose/(?P<pver>(\d+[\.\-_]*)+)"
+
+S = "${WORKDIR}/nose-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "\
+ python-unittest \
+ "
+
+BBCLASSEXTEND = "native nativesdk"