aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-02-06 03:48:09 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-15 20:06:29 -0800
commit0f6f9fb0c898fe47e95803836f73a1850ad3bc6b (patch)
tree1a93675a441d01cee4782e12a52bb582c3ee977f /meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
parent35e36f7f2d1f7e3ef70ba473a91fb6f946752f1b (diff)
downloadopenembedded-core-0f6f9fb0c898fe47e95803836f73a1850ad3bc6b.tar.gz
pax-utils: 1.1.6 -> 1.2.2
Export GNULIB_OVERRIDES_WINT_T to fix compile failure --------- 1099 make[4]: *** [printf-args.o] Error 1 1100 make[4]: *** Waiting for unfinished jobs.... 1101 In file included from ../../../pax-utils-1.2.2/autotools/gnulib/printf-args.h:41:0, 1102 from ../../../pax-utils-1.2.2/autotools/gnulib/printf-parse.h:29, 1103 from ../../../pax-utils-1.2.2/autotools/gnulib/printf-parse.c:36: 1104 ./wchar.h:476:6: error: #if with no expression 1105 # if 1106 ^ 1107 make[4]: *** [printf-parse.o] Error 1 --------- Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb')
-rw-r--r--meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb b/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
new file mode 100644
index 0000000000..a032a22c22
--- /dev/null
+++ b/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Security-focused ELF files checking tool"
+DESCRIPTION = "This is a small set of various PaX aware and related \
+utilities for ELF binaries. It can check ELF binary files and running \
+processes for issues that might be relevant when using ELF binaries \
+along with PaX, such as non-PIC code or executable stack and heap."
+HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
+
+SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.xz \
+"
+
+SRC_URI[md5sum] = "a580468318f0ff42edf4a8cd314cc942"
+SRC_URI[sha256sum] = "7f4a7f8db6b4743adde7582fa48992ad01776796fcde030683732f56221337d9"
+
+RDEPENDS_${PN} += "bash"
+
+export GNULIB_OVERRIDES_WINT_T = "0"
+
+do_configure_prepend() {
+ touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README
+}
+
+do_install() {
+ oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
+}
+
+BBCLASSEXTEND = "native"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
+"
+PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap"
+PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp"
+PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
+PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools"