aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_svn.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-01-20 11:05:16 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-24 11:23:55 +0000
commitda70cc9f33845d62943afc78168e56931d0a9b15 (patch)
tree57473f09f74e967a82c2895dc370c2d357b6edb8 /meta/recipes-devtools/opkg/opkg_svn.bb
parent391bc0715ee7fb3391f0719b2515fcf0bee9c4ad (diff)
downloadopenembedded-core-da70cc9f33845d62943afc78168e56931d0a9b15.tar.gz
opkg: move common code & metadata into opkg.inc to reduce code duplication
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_svn.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_svn.bb42
1 files changed, 1 insertions, 41 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_svn.bb b/meta/recipes-devtools/opkg/opkg_svn.bb
index f5f540d78e..c07d393019 100644
--- a/meta/recipes-devtools/opkg/opkg_svn.bb
+++ b/meta/recipes-devtools/opkg/opkg_svn.bb
@@ -1,14 +1,5 @@
require opkg.inc
-PROVIDES += "virtual/update-alternatives"
-RPROVIDES_update-alternatives-cworth += "update-alternatives"
-RCONFLICTS_update-alternatives-cworth = "update-alternatives-dpkg"
-RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-config-base"
-RDEPENDS_${PN}_virtclass-native = ""
-RDEPENDS_${PN}_virtclass-nativesdk = ""
-PACKAGE_ARCH_update-alternatives-cworth = "all"
-RREPLACES_${PN} = "opkg-nogpg"
-
SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
file://add_vercmp.patch \
file://add_uname_support.patch \
@@ -21,36 +12,5 @@ S = "${WORKDIR}/trunk"
SRCREV = "633"
PV = "0.1.8+svnr${SRCPV}"
-PR = "r5"
-
-PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}"
-
-FILES_update-alternatives-cworth${PKGSUFFIX} = "${bindir}/update-alternatives"
-FILES_libopkg${PKGSUFFIX}-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
-FILES_libopkg${PKGSUFFIX} = "${libdir}/*.so.* ${localstatedir}/lib/opkg/"
-
-# We need to create the lock directory
-do_install_append() {
- install -d ${D}${localstatedir}/lib/opkg
-}
-
-pkg_postinst_${PN} () {
-#!/bin/sh
-if [ "x$D" != "x" ]; then
- install -d $D${sysconfdir}/rcS.d
- # this happens at S98 where our good 'ole packages script used to run
- echo "#!/bin/sh
-opkg-cl configure
-rm -f /${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
-" > $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
- chmod 0755 $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
-fi
-
-update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
-}
-
-pkg_postrm_${PN} () {
-#!/bin/sh
-update-alternatives --remove opkg ${bindir}/opkg-cl
-}
+PR = "${INC_PR}.0"