aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/intltool/intltool/noperlcheck.patch
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2015-07-08 21:01:23 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-12 22:53:21 +0100
commitbebbcb10f467b40cc9a2fb64c824f2ef4142f7fe (patch)
tree448e211811208f700836640174079d751709184d /meta/recipes-devtools/intltool/intltool/noperlcheck.patch
parent64733935306d6b484db40b15e6e4938fbabf1d65 (diff)
downloadopenembedded-core-bebbcb10f467b40cc9a2fb64c824f2ef4142f7fe.tar.gz
intltool: Upgrade 0.50.2 -> 0.51.0
* Remove uclibc.patch as the whole localedir guessing code has been removed upstream. * Add patch to fix deprecation warnings (and the resulting broken install paths) when using Perl 5.22 (RB) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/intltool/intltool/noperlcheck.patch')
-rw-r--r--meta/recipes-devtools/intltool/intltool/noperlcheck.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/intltool/intltool/noperlcheck.patch b/meta/recipes-devtools/intltool/intltool/noperlcheck.patch
new file mode 100644
index 0000000000..853ee1a438
--- /dev/null
+++ b/meta/recipes-devtools/intltool/intltool/noperlcheck.patch
@@ -0,0 +1,40 @@
+In the target case, we can't check if perl exists or try running it. If we
+don't patch the code, the native perl location would be used, not the target
+which is also incorrect. We therefore disable this code and rely on the
+correct value of PERL being passed in.
+
+RP 31/8/2011
+
+Upstream-Status: Inappropriate [OE specific]
+
+diff --git a/configure.ac b/configure.ac
+index 5338a76..e709a2b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,24 +11,10 @@ AC_SUBST(pkgdatadir) dnl automake does not need this, but libtoolize does
+ aclocaldir='${datadir}'/aclocal
+ AC_SUBST(aclocaldir)
+
+-AC_PATH_PROG(PERL, perl)
+ if test -z "$PERL"; then
+- AC_MSG_ERROR([perl not found])
+-fi
+-AC_MSG_CHECKING([for perl >= 5.8.1])
+-$PERL -e "use 5.8.1;" > /dev/null 2>&1
+-if test $? -ne 0; then
+- AC_MSG_ERROR([perl 5.8.1 is required for intltool])
+-else
+- PERL_VERSION="`$PERL -e \"printf '%vd', $^V\"`"
+- AC_MSG_RESULT([$PERL_VERSION])
+-fi
+-AC_MSG_CHECKING([for XML::Parser])
+-if `$PERL -e "require XML::Parser" 2>/dev/null`; then
+- AC_MSG_RESULT([ok])
+-else
+- AC_MSG_ERROR([XML::Parser perl module is required for intltool])
++ AC_MSG_ERROR([PERL variable not set])
+ fi
++AC_SUBST(PERL)
+ AC_PATH_PROG(BZR, bzr)
+
+