summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dpkg
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-16 22:01:46 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-30 16:39:06 +0000
commitc90b1faa34e908c7f63e1a64027873858e6d7e8a (patch)
tree1b126fe1a8806f8cc36c744ed8d455c6345918a4 /meta/recipes-devtools/dpkg
parent018442ed2cd251f85212dfa1d03c0b24a0750bfa (diff)
downloadopenembedded-core-c90b1faa34e908c7f63e1a64027873858e6d7e8a.tar.gz
update-alternatives: Various fixes
dpkg-native's update-alternatives is broken for offline work so don't install it. Also list update-alternatives in the multiprovider whitelist to avoid unwanted multiple provider warnings when multiple package backends are enabled. (From OE-Core rev: 300336fc4a310ed16a14ad041744708d54aae189) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/dpkg')
-rw-r--r--meta/recipes-devtools/dpkg/dpkg.inc12
-rw-r--r--meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb2
2 files changed, 11 insertions, 3 deletions
diff --git a/meta/recipes-devtools/dpkg/dpkg.inc b/meta/recipes-devtools/dpkg/dpkg.inc
index 9929b3a734..041737b1d2 100644
--- a/meta/recipes-devtools/dpkg/dpkg.inc
+++ b/meta/recipes-devtools/dpkg/dpkg.inc
@@ -48,10 +48,18 @@ rm -f ${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
}
do_install_append () {
- mv ${D}${bindir}/update-alternatives ${D}${sbindir}
+ if [ "${PN}" = "dpkg-native" ]; then
+ # update-alternatives doesn't have an offline mode
+ rm ${D}${bindir}/update-alternatives
+ else
+ mv ${D}${bindir}/update-alternatives ${D}${sbindir}
+ fi
}
-PROVIDES += "virtual/update-alternatives"
+PROV = "virtual/update-alternatives"
+PROV_virtclass-native = ""
+
+PROVIDES += "${PROV}"
PACKAGES =+ "update-alternatives-dpkg"
FILES_update-alternatives-dpkg = "${sbindir}/update-alternatives ${localstatedir}/lib/dpkg/alternatives ${sysconfdir}/alternatives"
diff --git a/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb b/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb
index 8b45a00a6a..f1a0eebcd5 100644
--- a/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb
+++ b/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb
@@ -9,5 +9,5 @@ SRC_URI += "file://noman.patch \
SRC_URI[md5sum] = "d1731d4147c1ea3b537a4d094519a6dc"
SRC_URI[sha256sum] = "1ec1376471b04717a4497e5d7a27cd545248c92116898ce0c53ced8ea94267b5"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"