aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/distcc/files
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-07-26 08:26:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-27 15:44:23 +0100
commit782499eaa817f1beecc0aea5bfa075196f8e2a53 (patch)
tree5d2ad708a61e366de48aaf26994114dcff250c78 /meta/recipes-devtools/distcc/files
parent3212029f0967dd353fec8cc147d2b95031d1018a (diff)
downloadopenembedded-core-782499eaa817f1beecc0aea5bfa075196f8e2a53.tar.gz
distcc: fix makefile parameter order
When linking with gcc, the parameter is read from left to write, if *.o calls a function contained in libxxx, the parameter order should be "gcc ... *.o -lxxx". This commit fixes the problem in distcc. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-devtools/distcc/files')
-rw-r--r--meta/recipes-devtools/distcc/files/makefile-param-order.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/distcc/files/makefile-param-order.patch b/meta/recipes-devtools/distcc/files/makefile-param-order.patch
new file mode 100644
index 0000000000..fc57414f12
--- /dev/null
+++ b/meta/recipes-devtools/distcc/files/makefile-param-order.patch
@@ -0,0 +1,20 @@
+distcc: Put the "-lLIB" parameter in the end of the gcc command.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+Upstream-Status: Pending
+
+diff -ruN distcc-2.18.3-orig/Makefile.in distcc-2.18.3/Makefile.in
+--- distcc-2.18.3-orig/Makefile.in 2011-07-25 16:43:21.000000000 +0800
++++ distcc-2.18.3/Makefile.in 2011-07-25 16:45:39.000000000 +0800
+@@ -378,8 +378,8 @@
+
+ distccmon-gnome@EXEEXT@: $(mon_obj) $(gnome_obj)
+ $(CC) -o $@ $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(LIBS) \
+- $(GNOME_CFLAGS) $(GNOME_LIBS) \
+- $(mon_obj) $(gnome_obj)
++ $(GNOME_CFLAGS) \
++ $(mon_obj) $(gnome_obj) $(GNOME_LIBS)
+
+
+ ## Dist targets