aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_2.7.1.bb
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-05-07 11:44:34 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-12 08:40:56 +0100
commit9cad15c8bc14d7f371e518b443650d1380b16516 (patch)
treefb3dcd4aa5c15148ab91e99f66bca359c0e6817a /meta/recipes-devtools/bison/bison_2.7.1.bb
parenta54b5f93c5b5fa00c7099fcc51e916db145ecfc2 (diff)
downloadopenembedded-core-9cad15c8bc14d7f371e518b443650d1380b16516.tar.gz
bison: upgraded to 2.7.1
Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/bison/bison_2.7.1.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_2.7.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_2.7.1.bb b/meta/recipes-devtools/bison/bison_2.7.1.bb
new file mode 100644
index 0000000000..10bd8e3ebd
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_2.7.1.bb
@@ -0,0 +1,38 @@
+SUMMARY = "GNU Project parser generator (yacc replacement)."
+DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
+an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
+grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
+little trouble."
+HOMEPAGE = "http://www.gnu.org/software/bison/"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+SECTION = "devel"
+DEPENDS = "bison-native flex-native"
+
+BASE_SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
+ file://m4.patch \
+ file://dont-depend-on-help2man.patch \
+ "
+
+# No point in hardcoding path to m4, just use PATH
+EXTRA_OECONF += "M4=m4"
+
+SRC_URI = "${BASE_SRC_URI} \
+ file://fix_cross_manpage_building.patch \
+ "
+
+SRC_URI[md5sum] = "7be02eb973eccf388f1ae750fc09eed0"
+SRC_URI[sha256sum] = "b409adcbf245baadb68d2f66accf6fdca5e282cafec1b865f4b5e963ba8ea7fb"
+
+LDFLAGS_prepend_libc-uclibc = " -lrt "
+DEPENDS_class-native = "gettext-minimal-native"
+SRC_URI_class-native = "${BASE_SRC_URI}"
+
+inherit autotools gettext
+acpaths = "-I ${S}/m4"
+
+do_install_append_class-native() {
+ create_wrapper ${D}/${bindir}/bison \
+ BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
+}
+BBCLASSEXTEND = "native nativesdk"