summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-03-02 20:32:29 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-06 22:36:34 +0000
commit7977ff07d181d269bd52f98852d1076b268db614 (patch)
tree764e3d3c585ea94794e9ea9a81e3b72b64f46ad6 /meta/recipes-core
parent60dab210a9a2cc101f41ca5e46eed7e5e83ff89f (diff)
downloadopenembedded-core-7977ff07d181d269bd52f98852d1076b268db614.tar.gz
glib-2.0: call os.path.normpath on THISDIR
* some build environments have relative paths in THISDIR, e.g. from OEROOT set in: https://github.com/96boards/oe-rpb-manifest/blob/1e3345c26c56f77f3a15a3978f412a25955d2606/conf/bblayers.conf#L4 and then the paths in filename normalized in: filename = os.path.normpath(os.path.join(path, meson.cross.d, element)) don't match. * COREBASE used here before didn't have this issue because the value is already normalized when set in: meta/conf/layer.conf:COREBASE = '${@os.path.normpath("${LAYERDIR}/../")}' Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.66.7.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.66.7.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.66.7.bb
index 882a89da7a..a2fa5345b4 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.66.7.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.66.7.bb
@@ -31,7 +31,7 @@ def find_meson_cross_files(d):
if bb.data.inherits_class('native', d):
return ""
- thisdir = d.getVar("THISDIR")
+ thisdir = os.path.normpath(d.getVar("THISDIR"))
import collections
sitedata = siteinfo_data(d)
# filename -> found